mirror of
https://abf.rosa.ru/djam/zeronet.git
synced 2025-02-23 14:42:55 +00:00
103 lines
3.4 KiB
RPMSpec
103 lines
3.4 KiB
RPMSpec
%define oname ZeroNet
|
|
%define gitrev 952a1a1da8c32554e2c84a595eb96d661663053c
|
|
%define gitdate 20190216
|
|
%define debug %nil
|
|
%define debug_package %nil
|
|
|
|
Name: zeronet
|
|
Version: 0.7.1
|
|
Release: 1
|
|
Summary: ZeroNet
|
|
URL: https://zeronet.io
|
|
Source: https://github.com/HelloZeroNet/ZeroNet/archive/v%{version}/%{name}-%{version}.tar.gz
|
|
#Source0: %{oname}-%{gitrev}.zip
|
|
Source10: %{name}_starttor
|
|
Source11: %{name}_torrc
|
|
Source12: %{name}_start
|
|
Group: Development/Other
|
|
License: GPLv2
|
|
BuildArch: noarch
|
|
BuildRequires: pkgconfig(python3)
|
|
BuildRequires: python3egg(setuptools)
|
|
BuildRequires: python3egg(gevent) >= 1.1.0
|
|
BuildRequires: python3egg(msgpack) >= 0.4.4
|
|
BuildRequires: python3egg(base58)
|
|
BuildRequires: python3egg(merkletools)
|
|
BuildRequires: python3egg(pyelliptic) == 1.5.6
|
|
BuildRequires: python3egg(rsa)
|
|
BuildRequires: python3egg(pysocks)
|
|
BuildRequires: python3egg(pyasn1)
|
|
BuildRequires: python3egg(websocket_client)
|
|
BuildRequires: python3egg(gevent-websocket)
|
|
BuildRequires: python3egg(bencode.py)
|
|
BuildRequires: python3egg(coincurve)
|
|
BuildRequires: python3egg(python-bitcoinlib)
|
|
BuildRequires: python3egg(maxminddb)
|
|
BuildRequires: imagemagick
|
|
Requires: python3egg(gevent) >= 1.1.0
|
|
Requires: python3egg(msgpack) >= 0.4.4
|
|
Requires: python3egg(base58)
|
|
Requires: python3egg(merkletools)
|
|
Requires: python3egg(pyelliptic) == 1.5.6
|
|
Requires: python3egg(rsa)
|
|
Requires: python3egg(pysocks)
|
|
Requires: python3egg(pyasn1)
|
|
Requires: python3egg(websocket_client)
|
|
Requires: python3egg(gevent-websocket)
|
|
Requires: python3egg(bencode.py)
|
|
Requires: python3egg(coincurve)
|
|
Requires: python3egg(python-bitcoinlib)
|
|
Requires: python3egg(maxminddb)
|
|
Requires: tor
|
|
|
|
%description
|
|
Decentralized websites using Bitcoin crypto and
|
|
the BitTorrent network
|
|
|
|
%prep
|
|
%setup -qn %{oname}-%{version}
|
|
|
|
%build
|
|
#non build
|
|
|
|
%install
|
|
install -d %{buildroot}/{%{_bindir},%{_datadir}/{%{name},applications,pixmaps},%{_iconsdir}/hicolor/{16x16,32x32,24x24,48x48}/apps/%{name}}
|
|
install -d %{buildroot}/%{python3_sitelib}/%{name}/tools
|
|
install -Dm0755 start.py zeronet.py %{buildroot}/%{python3_sitelib}/%{name}
|
|
install -Dm0755 %{SOURCE10} %{buildroot}/%{python3_sitelib}/%{name}/tools/start.cmd
|
|
install -Dm0644 %{SOURCE11} %{buildroot}/%{python3_sitelib}/%{name}/tools/torrc
|
|
install -Dm0755 %{SOURCE12} %{buildroot}/%{_bindir}/%{name}
|
|
cp -r plugins src %{buildroot}%{python3_sitelib}/%{name}
|
|
|
|
# menu-entry
|
|
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop <<EOF
|
|
[Desktop Entry]
|
|
Name=ZeroNet
|
|
Name[ru]=Анонимная сеть ZeroNet
|
|
GenericName=ZeroNet
|
|
GenericName[ru]=ZeroNet
|
|
Comment=Decentralisations Internet
|
|
Comment[ru]=Децентрализованный Интернет
|
|
Exec=%{name}
|
|
Icon=%{name}.png
|
|
Terminal=false
|
|
Type=Application
|
|
StartupNotify=true
|
|
Categories=Application;
|
|
EOF
|
|
|
|
#convert src/Ui/media/img/logo.psd
|
|
%define icon src/Ui/media/img/logo.psd
|
|
%{_bindir}/convert -scale 32 %{icon} %{buildroot}%{_datadir}/pixmaps/%{name}.png
|
|
%{_bindir}/convert -scale 16 %{icon} %{buildroot}%{_iconsdir}/hicolor/16x16/apps/%{name}.png
|
|
%{_bindir}/convert -scale 24 %{icon} %{buildroot}%{_iconsdir}/hicolor/24x24/apps/%{name}.png
|
|
%{_bindir}/convert -scale 32 %{icon} %{buildroot}%{_iconsdir}/hicolor/32x32/apps/%{name}.png
|
|
%{_bindir}/convert -scale 48 %{icon} %{buildroot}%{_iconsdir}/hicolor/48x48/apps/%{name}.png
|
|
|
|
%files
|
|
%doc LICENSE
|
|
%{_bindir}/%{name}
|
|
%{python3_sitelib}
|
|
%{_iconsdir}/hicolor
|
|
%{_datadir}/pixmaps
|
|
%{_datadir}/applications/%{name}.desktop
|