mirror of
https://abf.rosa.ru/djam/yamllint.git
synced 2025-02-23 05:52:55 +00:00
67 lines
1.6 KiB
RPMSpec
67 lines
1.6 KiB
RPMSpec
%global pypi_name yamllint
|
|
%define debug %nil
|
|
%define debug_package %nil
|
|
|
|
Name: %{pypi_name}
|
|
Version: 1.29.0
|
|
Release: 1
|
|
Summary: A linter for YAML files
|
|
License: GPLv3+
|
|
URL: https://github.com/adrienverge/yamllint
|
|
#Source0: https://pypi.python.org/packages/source/y/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
|
|
Source0: %{url}/archive/v%{version}/%{pypi_name}-%{version}.tar.gz
|
|
Group: Development/Python
|
|
BuildArch: noarch
|
|
Requires: python3egg(pathspec)
|
|
Requires: python3egg(pyyaml)
|
|
Requires: python3egg(setuptools)
|
|
|
|
BuildRequires: pkgconfig(python3)
|
|
BuildRequires: python3egg(setuptools)
|
|
BuildRequires: python3egg(nose)
|
|
BuildRequires: python3egg(pathspec)
|
|
BuildRequires: python3egg(pyyaml)
|
|
|
|
BuildRequires: pkgconfig(python-3.8)
|
|
BuildRequires: python38-setuptools
|
|
BuildRequires: python38-nose
|
|
BuildRequires: python38-pathspec
|
|
BuildRequires: python38-pyyaml
|
|
|
|
%description
|
|
A linter for YAML files.
|
|
|
|
yamllint does not only check for syntax validity, but for weirdnesses like key
|
|
repetition and cosmetic problems such as lines length, trailing spaces,
|
|
indentation, etc.
|
|
|
|
%prep
|
|
%setup -qn %{pypi_name}-%{version}
|
|
rm -rf %{pypi_name}.egg-info
|
|
|
|
%build
|
|
%py3_build
|
|
%py38_build
|
|
|
|
%install
|
|
%py3_install
|
|
|
|
pushd %{buildroot}%{_bindir}
|
|
mv %{pypi_name} %{pypi_name}3
|
|
popd
|
|
|
|
%py38_install
|
|
|
|
%check
|
|
%{__python3} setup.py test
|
|
%{__python3.8} setup.py test
|
|
%files
|
|
%doc README.rst LICENSE
|
|
%{_bindir}/%{pypi_name}
|
|
%{py3_puresitedir}/%{pypi_name}
|
|
%{py3_puresitedir}/%{pypi_name}-*
|
|
|
|
%{py38_puresitedir}/%{pypi_name}
|
|
%{py38_puresitedir}/%{pypi_name}-*
|
|
|
|
%changelog
|