version-checker/version-checker.spec
2024-06-07 11:42:20 +00:00

39 lines
928 B
RPMSpec

%define debug %nil
%define debug_package %nil
Name: version-checker
Version: 0.6.0
Release: 1
Summary: Kubernetes utility for exposing image versions in use
URL: https://jetstack.io
Source0: https://github.com/jetstack/version-checker/archive/v%{version}/%{name}-%{version}.tar.gz
License: ASL-2.0
Group: Development/Other
BuildRequires: go
BuildRequires: git-core
BuildRequires: upx
%description
version-checker is a Kubernetes utility for observing the
current versions of images running in the cluster, as well
as the latest available upstream. These checks get exposed
as Prometheus metrics to be viewed on a dashboard, or soft
alert cluster operators
%prep
%setup -q
%build
export GOPROXY=direct
CGO_ENABLED=0 go build -ldflags="-s -w" -o ./bin/%{name} ./cmd/.
upx ./bin/%{name}
%install
install -Dm0755 ./bin/%{name} %{buildroot}%{_bindir}/%{name}
%files
%doc README.md LICENSE deploy/
%{_bindir}/%{name}