version-checker/version-checker.spec
Your Name 8c5699a35d
All checks were successful
Run CI/CD... / main (push) Successful in 10m19s
0.8.6
2025-02-20 09:45:53 +00:00

39 lines
953 B
RPMSpec

%define debug %nil
%define debug_package %nil
Name: version-checker
Version: 0.8.6
Release: 1
Summary: Kubernetes utility for exposing image versions in use
URL: https://jetstack.io
Source0: https://github.com/jetstack/version-checker/archive/v%{version}/%{name}-%{version}.tar.gz
License: ASL-2.0
Group: Development/Other
BuildRequires: go
BuildRequires: git-core
BuildRequires: upx
%description
version-checker is a Kubernetes utility for observing the
current versions of images running in the cluster, as well
as the latest available upstream. These checks get exposed
as Prometheus metrics to be viewed on a dashboard, or soft
alert cluster operators
%prep
%setup -q
%build
export GOPROXY=https://proxy.golang.org,direct
CGO_ENABLED=0 go build -ldflags="-s -w" -o ./bin/%{name} ./cmd/.
upx ./bin/%{name}
%install
install -Dm0755 ./bin/%{name} %{buildroot}%{_bindir}/%{name}
%files
%doc README.md LICENSE deploy/
%{_bindir}/%{name}