mirror of
https://abf.rosa.ru/djam/u-boot-tools.git
synced 2025-02-22 21:52:49 +00:00
61 lines
1.7 KiB
RPMSpec
61 lines
1.7 KiB
RPMSpec
%define debug_package %nil
|
|
%global optflags %(echo %{optflags} | sed -e 's/-ffat-lto-objects//g' -e 's/-fvar-tracking-assignments//g')
|
|
|
|
Name: u-boot-tools
|
|
Version: 2025.01
|
|
Release: 1
|
|
Summary: Tools for the u-boot Firmware
|
|
Group: System/Kernel and hardware
|
|
Epoch: 1
|
|
URL: https://docs.u-boot.org/en/v%{version}/
|
|
Source0: https://ftp.denx.de/pub/u-boot/u-boot-%{version}.tar.bz2
|
|
License: GPLv2
|
|
BuildRequires: bzip2
|
|
BuildRequires: dtc
|
|
BuildRequires: bison
|
|
BuildRequires: flex
|
|
BuildRequires: pkgconfig(python3)
|
|
BuildRequires: pkgconfig(python-3.8)
|
|
BuildRequires: python3egg(setuptools)
|
|
BuildRequires: python38-setuptools
|
|
BuildRequires: pkgconfig(openssl3.3)
|
|
BuildRequires: %{_lib}tinfo5
|
|
BuildRequires: ncurses-devel
|
|
BuildRequires: llvm17
|
|
Provides: uboot-mkimage
|
|
|
|
%description
|
|
Das U-Boot (or just "U-Boot" for short)
|
|
is Open Source Firmware for Embedded PowerPC, ARM, MIPS and x86 processors.
|
|
This package contains:
|
|
mkimage a tool that creates kernel bootable images for u-boot.
|
|
|
|
%prep
|
|
%setup -q -n u-boot-%{version}
|
|
|
|
sed -i 's/tinfo/ncursesw/g' tools/Makefile
|
|
|
|
%build
|
|
/usr/libexec/python3.8 -m venv .
|
|
. ./bin/activate
|
|
|
|
%set_build_flags
|
|
export PYTHONPATH=%{python38_sitelib}
|
|
export PYTHON3=/usr/libexec/python3.8
|
|
export PYTHON=/usr/libexec/python3.8
|
|
|
|
#export PATH=/opt/openssl1.1/include/openssl/:/opt/openssl1.1/lib/:$PATH
|
|
|
|
make defconfig
|
|
sed -i -e "s:-g ::" tools/Makefile || die
|
|
%make u-boot
|
|
#make HOSTCC=%{__cc} HOSTSTRIP=%{__strip} USE_PRIVATE_LIBGG=yes tools-all PYTHON3=/usr/libexec/python3.8
|
|
|
|
%install
|
|
install -D -m 0755 tools/mkimage %{buildroot}%{_bindir}/mkimage
|
|
install -D -m 0644 doc/mkimage.1 %{buildroot}%{_mandir}/man1/mkimage.1
|
|
gzip %{buildroot}%{_mandir}/man1/*
|
|
|
|
%files
|
|
%{_bindir}/mkimage
|
|
%{_mandir}/man1/mkimage.1.*
|