mirror of
https://abf.rosa.ru/djam/toxygen.git
synced 2025-02-23 10:12:54 +00:00
76 lines
2.1 KiB
RPMSpec
76 lines
2.1 KiB
RPMSpec
%define debug %nil
|
|
%define debug_package %nil
|
|
|
|
Name: toxygen
|
|
Summary: Messsanger for tox
|
|
Version: 0.1.1
|
|
Release: 1
|
|
Group: Networking/Instant messaging
|
|
License: GPLv3
|
|
URL: https://github.com/xveduk/toxygen
|
|
Source: %{name}-%{version}.tar.gz
|
|
Patch: %{name}_start.patch
|
|
BuildArch: noarch
|
|
BuildRequires: python >= 2.7
|
|
BuildRequires: fdupes
|
|
Requires: python >= 2.7
|
|
Requires: pyside
|
|
Requires: pyaudio
|
|
Requires: toxcore
|
|
|
|
%description
|
|
Python based messanger for tox network
|
|
|
|
%prep
|
|
%setup -q
|
|
%patch -p0
|
|
|
|
%build
|
|
#nobuild
|
|
|
|
%install
|
|
install -d %{buildroot}%{_bindir}
|
|
install -d %{buildroot}%{python_sitelib}/%{name}/{images,sounds,styles/rc,translations}
|
|
install -d %{buildroot}%{_datadir}/applications
|
|
install -d %{buildroot}%{_iconsdir}
|
|
|
|
install -Dm0644 src/*.py %{buildroot}%{python_sitelib}/%{name}
|
|
install -Dm0644 src/images/* %{buildroot}%{python_sitelib}/%{name}/images
|
|
install -Dm0644 src/sounds/* %{buildroot}%{python_sitelib}/%{name}/sounds
|
|
install -Dm0644 src/translations/* %{buildroot}%{python_sitelib}/%{name}/translations
|
|
install -Dm0644 src/styles/rc/*.png %{buildroot}%{python_sitelib}/%{name}/styles/rc
|
|
install -Dm0644 src/styles/*.* %{buildroot}%{python_sitelib}/%{name}/styles
|
|
|
|
install -Dm0644 src/images/icon.png %{buildroot}%{_iconsdir}/%{name}.png
|
|
|
|
ln -s %{python_sitelib}/%{name}/main.py %{buildroot}%{_bindir}/%{name}
|
|
|
|
chmod 0755 %{buildroot}%{python_sitelib}/%{name}/main.py
|
|
|
|
# menu-entry
|
|
mkdir -p %{buildroot}%{_datadir}/applications
|
|
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop <<EOF
|
|
[Desktop Entry]
|
|
Name=toxygen
|
|
Name[ru]=Клиент сети tox
|
|
GenericName=toxygen
|
|
GenericName[ru]=Клиент сети tox
|
|
Comment=Messanger
|
|
Comment[ru]=Клиент мгновенных сообщений, голосовых и видео чатов для распределенной сети tox
|
|
Exec=%{name}
|
|
Icon=%{name}
|
|
Terminal=false
|
|
Type=Application
|
|
StartupNotify=true
|
|
Categories=Application;X-Networking;
|
|
EOF
|
|
|
|
%py_compile -O %{buildroot}%{python_sitelib}/%{name}
|
|
%fdupes %{buildroot}%{python_sitelib}/%{name}
|
|
|
|
%files
|
|
%doc README.md LICENSE.md
|
|
%{_bindir}/%{name}
|
|
%{python_sitelib}/%{name}
|
|
%{_datadir}/applications/%{name}.desktop
|
|
%{_iconsdir}/%{name}.png
|