mirror of
https://abf.rosa.ru/djam/tfsec.git
synced 2025-02-22 23:52:51 +00:00
37 lines
1,005 B
RPMSpec
37 lines
1,005 B
RPMSpec
%define debug %nil
|
|
%define debug_package %nil
|
|
|
|
Name: tfsec
|
|
Version: 1.28.13
|
|
Release: 1
|
|
Summary: Security scanner for your Terraform code
|
|
URL: https://tfsec.dev
|
|
Source0: https://github.com/aquasecurity/tfsec/archive/v%{version}/%{name}-%{version}.tar.gz
|
|
License: MIT
|
|
Group: Development/Other
|
|
BuildRequires: go >= 1.11
|
|
BuildRequires: git-core
|
|
BuildRequires: upx
|
|
|
|
%description
|
|
tfsec uses static analysis of your terraform templates
|
|
to spot potential security issues. Now with terraform CDK support.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
#GO111MODULE=on CGO_ENABLED=0 go build -ldflags "-X github.com/aquasecurity/tfsec/version.Version=%{version}" ./cmd/tfsec
|
|
export GOPROXY=https://proxy.golang.org,direct
|
|
|
|
GO111MODULE=on CGO_ENABLED=0 go build -ldflags "-X github.com/aquasecurity/tfsec/version.Version=%{version} -s -w -extldflags \"-fno-PIC -static\"" -o bin/%{name} ./cmd/%{name}/
|
|
|
|
upx bin/*
|
|
|
|
%install
|
|
install -Dm0755 bin/%{name} %{buildroot}%{_bindir}/%{name}
|
|
|
|
%files
|
|
%doc README.md LICENSE
|
|
%{_bindir}/%{name}
|
|
|