mirror of
https://abf.rosa.ru/djam/swig.git
synced 2025-02-23 17:12:54 +00:00
84 lines
2 KiB
RPMSpec
84 lines
2 KiB
RPMSpec
%bcond_with guile
|
|
%bcond_with mono
|
|
%bcond_with ocaml
|
|
|
|
Summary: Simplified Wrapper and Interface Generator (SWIG)
|
|
Name: swig
|
|
Version: 4.3.0
|
|
Release: 1
|
|
Epoch: 1
|
|
License: BSD
|
|
Group: Development/Other
|
|
URL: https://www.swig.org
|
|
Source0: http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
|
Patch0: swig-3.0.10-octave.patch
|
|
BuildRequires: bison
|
|
BuildRequires: imake
|
|
BuildRequires: libtool
|
|
%if %{with mono}
|
|
BuildRequires: mono
|
|
BuildRequires: pkgconfig(mono)
|
|
%endif
|
|
%if %{with ocaml}
|
|
BuildRequires: ocaml
|
|
%endif
|
|
BuildRequires: boost-devel
|
|
BuildRequires: libstdc++-devel
|
|
BuildRequires: lua-devel
|
|
BuildRequires: perl-devel
|
|
BuildRequires: php-devel
|
|
BuildRequires: ruby-devel
|
|
BuildRequires: tcl-devel
|
|
%if %{with guile}
|
|
BuildRequires: pkgconfig(guile-2.0)
|
|
%endif
|
|
BuildRequires: pkgconfig(libpcre)
|
|
BuildRequires: pkgconfig(lua)
|
|
BuildRequires: pkgconfig(python)
|
|
BuildRequires: pkgconfig(libpcre2-posix)
|
|
Obsoletes: swig-devel < 2.0.7
|
|
Conflicts: swig2
|
|
|
|
%description
|
|
SWIG takes an interface description file written in a combination of C/C++
|
|
and special directives and produces interfaces to Perl, Python, and Tcl.
|
|
It allows scripting languages to use C/C++ code with minimal effort.
|
|
|
|
%files
|
|
%doc ANNOUNCE INSTALL CHANGES CHANGES.current LICENSE README TODO
|
|
%{_bindir}/swig
|
|
%{_bindir}/ccache-swig
|
|
%{_datadir}/swig
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%package doc
|
|
Summary: Documentation and examples for %{name}
|
|
Group: Development/C
|
|
Requires: %{name} = %{EVRD}
|
|
|
|
%description doc
|
|
SWIG takes an interface description file written in a combination of C/C++
|
|
and special directives and produces interfaces to Perl, Python, and Tcl.
|
|
It allows scripting languages to use C/C++ code with minimal effort.
|
|
|
|
Install the %{name}-doc package if you want to look at example and
|
|
documentation.
|
|
|
|
%files doc
|
|
%doc Examples Doc/Manual
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%prep
|
|
%setup -q
|
|
#patch0 -p1 -b .octave~
|
|
|
|
%build
|
|
./autogen.sh
|
|
%configure2_5x
|
|
%make
|
|
|
|
%install
|
|
%makeinstall_std
|
|
|