python38-psutil/python38-psutil.spec
NixTux Commit Bot 5f93e08f03 manual fix 1
2020-05-31 19:19:11 +03:00

63 lines
1.9 KiB
RPMSpec

%global __provides_exclude ^(python3egg|python3dist)
%global __requires_exclude ^(python3egg|python3dist)
%global srcname psutil
%global sum A process and system utilities module for Python
# Filter Python modules from Provides
%global __provides_exclude_from ^(%{python2_sitearch}|%{python38_sitearch})/.*\\.so$
Name: python-%{srcname}
Version: 5.6.7
Release: 1
Summary: %{sum}
Group: Development/Python
License: BSD
URL: https://github.com/giampaolo/psutil
Source0: https://github.com/giampaolo/psutil/archive/release-%{version}.tar.gz#/%{srcname}-%{version}.tar.gz
BuildRequires: gcc
BuildRequires: python38-devel
%description
psutil is a module providing an interface for retrieving information on all
running processes and system utilization (CPU, memory, disks, network, users) in
a portable way by using Python, implementing many functionalities offered by
command line tools such as: ps, top, df, kill, free, lsof, free, netstat,
ifconfig, nice, ionice, iostat, iotop, uptime, pidof, tty, who, taskset, pmap.
%package -n python38-psutil
Summary: %{sum}
Group: Development/Python
%description -n python38-psutil
psutil is a module providing an interface for retrieving information on all
running processes and system utilization (CPU, memory, disks, network, users) in
a portable way by using Python 3, implementing many functionalities offered by
command line tools such as: ps, top, df, kill, free, lsof, free, netstat,
ifconfig, nice, ionice, iostat, iotop, uptime, pidof, tty, who, taskset, pmap.
%prep
%autosetup -p0 -n %{srcname}-release-%{version}
# Remove shebangs
find psutil -name \*.py | while read file; do
sed -i.orig -e '1{/^#!/d}' $file && \
touch -r $file.orig $file && \
rm $file.orig
done
%build
%py38_build
%install
%py38_install
%files -n python38-%{srcname}
%license LICENSE
%doc CREDITS HISTORY.rst README.rst
%{python38_sitearch}/%{srcname}/
%{python38_sitearch}/*.egg-info