python38-psutil/python-psutil.spec
Your Name a609263a05
Some checks failed
Run CI/CD... / main (push) Failing after 7s
6.1.1
2025-02-11 07:50:01 +00:00

74 lines
No EOL
2.1 KiB
RPMSpec

%global __provides_exclude ^(python3egg|python3dist)
%global __requires_exclude ^(python3egg|python3dist)
%global srcname psutil
%global sum A process and system utilities module for Python
# Filter Python modules from Provides
%global __provides_exclude_from ^(%{python2_sitearch}|%{python38_sitearch})/.*\\.so$
Name: python-%{srcname}
Version: 6.1.1
Release: 1
Summary: %{sum}
Group: Development/Python
License: BSD
URL: https://github.com/giampaolo/psutil
Source0: %{url}/archive/release-%{version}.tar.gz#/%{srcname}-%{version}.tar.gz
BuildRequires: gcc
BuildRequires: pkgconfig(python)
BuildRequires: python-setuptools
BuildRequires: pkgconfig(python-3.8)
BuildRequires: python38-setuptools
%description
psutil is a module providing an interface for retrieving
information on all running processes and system utilization
(CPU, memory, disks, network, users) in a portable way by
using Python, implementing many functionalities offered by
command line tools such as: ps, top, df, kill, free, lsof,
free, netstat, ifconfig, nice, ionice, iostat, iotop, uptime,
pidof, tty, who, taskset, pmap.
%package -n python38-psutil
Summary: %{sum}
Group: Development/Python
%description -n python38-psutil
psutil is a module providing an interface for retrieving
information on all running processes and system utilization
(CPU, memory, disks, network, users) in a portable way by.
using Python, implementing many functionalities offered by
command line tools such as: ps, top, df, kill, free, lsof,.
free, netstat, ifconfig, nice, ionice, iostat, iotop, uptime,
pidof, tty, who, taskset, pmap.
%prep
%setup -qn %{srcname}-release-%{version}
# Remove shebangs
find psutil -name \*.py | while read file; do
sed -i.orig -e '1{/^#!/d}' $file && \
touch -r $file.orig $file && \
rm $file.orig
done
%build
%py_build
%py38_build
%install
%py_install
%py38_install
%files -n python38-%{srcname}
%doc CREDITS HISTORY.rst README.rst LICENSE
%{python38_sitearch}/%{srcname}/
%{python38_sitearch}/*.egg-info
%files
%doc CREDITS HISTORY.rst README.rst LICENSE
%{python_sitearch}/%{srcname}/
%{python_sitearch}/*.egg-info