python-sphinxcontrib-log-ca.../python-sphinxcontrib-log-cabinet.spec
2020-06-05 12:34:34 +10:00

78 lines
2 KiB
RPMSpec

%bcond_with python2
%define module sphinxcontrib-log-cabinet
Summary: Organize changelogs generated by versionadded etc
Name: python-%{module}
Version: 1.0.1
Release: 2
License: BSD
Group: Development/Python
Url: https://github.com/davidism/sphinxcontrib-log-cabinet
Source0: https://files.pythonhosted.org/packages/75/26/0687391e10c605a4d0c7ebe118c57c51ecc687128bcdae5803d9b96def81/sphinxcontrib-log-cabinet-1.0.1.tar.gz
%if %{with python2}
BuildRequires: pkgconfig(python2)
BuildRequires: pythonegg(setuptools)
%endif
BuildArch: noarch
%description
Organize changelogs generated by versionadded, versionchanged, deprecated
directives. The log will be sorted by newest to oldest version. For HTML docs,
older versions will be collapsed by default.
%if %{with python2}
%files
%doc python2/CHANGES.rst python2/LICENSE.rst python2/README.rst
%{python2_sitelib}/sphinxcontrib/*
%{python2_sitelib}/*.egg-info/*
%{python2_sitelib}/sphinxcontrib_log_cabinet-%{version}*.pth
%endif
#----------------------------------------------------------------------------
%package -n python3-%{module}
Summary: Organize changelogs generated by versionadded etc
Group: Development/Python
BuildRequires: pkgconfig(python3)
BuildRequires: python3egg(setuptools)
%description -n python3-%{module}
Organize changelogs generated by versionadded, versionchanged, deprecated
directives. The log will be sorted by newest to oldest version. For HTML docs,
older versions will be collapsed by default.
%files -n python3-%{module}
%doc python3/CHANGES.rst python3/LICENSE.rst python3/README.rst
%{python3_sitelib}/sphinxcontrib/*
%{python3_sitelib}/*.egg-info/*
%{python3_sitelib}/sphinxcontrib_log_cabinet-%{version}*.pth
#----------------------------------------------------------------------------
%prep
%setup -qc -n %{module}-%{version}
mv %{module}-%{version} python2
cp -r python2 python3
%build
%if %{with python2}
pushd python2
%py2_build
popd
%endif
pushd python3
%py3_build
popd
%install
pushd python3
%py3_install
popd
%if %{with python2}
pushd python2
%py2_install
popd
%endif