python-sphinxcontrib-log-ca.../python-sphinxcontrib-log-cabinet.spec
2023-10-26 22:19:30 +00:00

92 lines
2.7 KiB
Python

%define oname sphinxcontrib-log-cabinet
Summary: Organize changelogs generated by versionadded etc
Name: python-%{oname}
Version: 1.0.1
Release: 2
URL: https://github.com/davidism/sphinxcontrib-log-cabinet
Source0: https://files.pythonhosted.org/packages/75/26/0687391e10c605a4d0c7ebe118c57c51ecc687128bcdae5803d9b96def81/sphinxcontrib-log-cabinet-1.0.1.tar.gz
License: BSD
Group: Development/Python
BuildArch: noarch
BuildRequires: pkgconfig(python)
BuildRequires: pythonegg(setuptools)
BuildRequires: python-pkg-resources
BuildRequires: python3-pkg-resources
BuildRequires: python38-pkg-resources
#BuildRequires: python-sphinx
#BuildRequires: python3-sphinx
#BuildRequires: python38-sphinx
BuildRequires: python38-devel
BuildRequires: python38-setuptools
%description
Organize changelogs generated by versionadded, versionchanged, deprecated
directives. The log will be sorted by newest to oldest version. For HTML docs,
older versions will be collapsed by default.
#==============================================================================
%package -n python3-%{oname}
Summary: Organize changelogs generated by versionadded etc
Group: Development/Python
BuildRequires: pkgconfig(python3)
BuildRequires: python3egg(setuptools)
%description -n python3-%{oname}
Organize changelogs generated by versionadded, versionchanged, deprecated
directives. The log will be sorted by newest to oldest version. For HTML docs,
older versions will be collapsed by default.
%files -n python3-%{oname}
%doc python3/CHANGES.rst python3/LICENSE.rst python3/README.rst
%{python3_sitelib}/sphinxcontrib/*
%{python3_sitelib}/*.egg-info/*
%{python3_sitelib}/sphinxcontrib_log_cabinet-%{version}*.pth
#==============================================================================
%package -n python38-%{oname}
Summary: Organize changelogs generated by versionadded etc
Group: Development/Python
Requires: python38
%description -n python38-%{oname}
Organize changelogs generated by versionadded, versionchanged, deprecated.
directives. The log will be sorted by newest to oldest version. For HTML docs,.
older versions will be collapsed by default.
%files -n python38-%{oname}
%doc python3/CHANGES.rst python3/LICENSE.rst python3/README.rst
%{python38_sitelib}/sphinxcontrib/*
%{python38_sitelib}/*.egg-info/*
%{python38_sitelib}/sphinxcontrib_log_cabinet-%{version}*.pth
#==============================================================================
%prep
%setup -qc -n %{oname}-%{version}
mv %{oname}-%{version} python2
cp -r python2 python3
%build
pushd python2
#py_build
#python2 setup.py build
popd
pushd python3
%py3_build
%py38_build
popd
%install
pushd python3
%py3_install
%py38_install
popd
pushd python2
#py_install
popd