mirror of
https://abf.rosa.ru/djam/python-sphinx-issues.git
synced 2025-02-24 14:02:56 +00:00
52 lines
1.6 KiB
RPMSpec
52 lines
1.6 KiB
RPMSpec
%define pypi_name sphinx-issues
|
||
|
||
Summary: A Sphinx extension for linking to your project’s issue tracker
|
||
Name: python-%{pypi_name}
|
||
Version: 3.0.1
|
||
Release: 2
|
||
License: BSD
|
||
Group: Development/Python
|
||
Url: https://github.com/sloria/sphinx-issues
|
||
Source0: https://pypi.io/packages/source/s/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
|
||
BuildRequires: pkgconfig(python3)
|
||
BuildRequires: python3egg(setuptools)
|
||
BuildArch: noarch
|
||
|
||
%description
|
||
A Sphinx extension for linking to your project’s issue tracker. Includes roles
|
||
for linking to issues, pull requests, user profiles, with built-in support for
|
||
GitHub (though this works with other services).
|
||
|
||
#----------------------------------------------------------------------------
|
||
|
||
%package -n python3-%{pypi_name}
|
||
Summary: A Sphinx extension for linking to your project’s issue tracker
|
||
Group: Development/Python
|
||
Provides: python3egg(sphinx-issues) = %{EVRD}
|
||
Provides: python3dist(sphinx-issues) = %{EVRD}
|
||
Provides: python3egg(sphinx_issues) = %{EVRD}
|
||
Provides: python3dist(sphinx_issues) = %{EVRD}
|
||
|
||
|
||
%description -n python3-%{pypi_name}
|
||
A Sphinx extension for linking to your project’s issue tracker. Includes roles
|
||
for linking to issues, pull requests, user profiles, with built-in support for
|
||
GitHub (though this works with other services).
|
||
|
||
%files -n python3-%{pypi_name}
|
||
%license LICENSE
|
||
%doc README.rst
|
||
%{python3_sitelib}/*.egg-info/*
|
||
%{python3_sitelib}/sphinx_*.py*
|
||
%{python3_sitelib}/__pycache__/*
|
||
|
||
#----------------------------------------------------------------------------
|
||
|
||
%prep
|
||
%autosetup -p1 -n %{pypi_name}-%{version}
|
||
|
||
%build
|
||
%py3_build
|
||
|
||
%install
|
||
%py3_install
|