python-sphinx-issues/python-sphinx-issues.spec
Your Name 84be239a86
All checks were successful
Run CI/CD... / main (push) Successful in 5m46s
3.0.1
2025-02-10 18:34:44 +00:00

80 lines
No EOL
2.5 KiB
RPMSpec
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

%define pypi_name sphinx-issues
Summary: A Sphinx extension for linking to your projects issue tracker
Name: python-%{pypi_name}
Version: 3.0.1
Release: 4
License: BSD
Group: Development/Python
Url: https://github.com/sloria/sphinx-issues
Source0: https://pypi.io/packages/source/s/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
BuildRequires: pkgconfig(python3)
BuildRequires: python3egg(setuptools)
BuildRequires: python38-devel
BuildRequires: python38-setuptools
BuildArch: noarch
%description
A Sphinx extension for linking to your projects issue tracker.
Includes roles for linking to issues, pull requests, user
profiles, with built-in support for GitHub (though this works
with other services).
#----------------------------------------------------------------------------
%package -n python3-%{pypi_name}
Summary: A Sphinx extension for linking to your projects issue tracker
Group: Development/Python
#Provides: python3egg(sphinx-issues) = %{EVRD}
#Provides: python3dist(sphinx-issues) = %{EVRD}
#Provides: python3egg(sphinx_issues) = %{EVRD}
#Provides: python3dist(sphinx_issues) = %{EVRD}
%description -n python3-%{pypi_name}
A Sphinx extension for linking to your projects issue tracker.
Includes roles for linking to issues, pull requests, user
profiles, with built-in support for GitHub (though this works
with other services).
%files -n python3-%{pypi_name}
%doc LICENSE README.rst
%{python3_sitelib}/*.egg-info/*
%{python3_sitelib}/sphinx_*.py*
#{python3_sitelib}/__pycache__/*
#----------------------------------------------------------------------------
%package -n python38-%{pypi_name}
Summary: A Sphinx extension for linking to your projects issue tracker
Group: Development/Python
Provides: python38egg(sphinx-issues) = %{EVRD}
Provides: python38dist(sphinx-issues) = %{EVRD}
Provides: python38egg(sphinx_issues) = %{EVRD}
Provides: python38dist(sphinx_issues) = %{EVRD}
%description -n python38-%{pypi_name}
A Sphinx extension for linking to your projects issue tracker.
Includes roles for linking to issues, pull requests, user
profiles, with built-in support for GitHub (though this works
with other services).
%files -n python38-%{pypi_name}
%doc LICENSE README.rst
%{python38_sitelib}/*.egg-info/*
%{python38_sitelib}/sphinx_*.py*
%{python38_sitelib}/__pycache__/*
#----------------------------------------------------------------------------
%prep
%setup -qn %{pypi_name}-%{version}
%build
%py3_build
%py38_build
%install
%py3_install
%py38_install