python-six/python-six.spec
2024-01-24 00:07:29 +00:00

111 lines
2.8 KiB
RPMSpec

%define oname six
Name: python-%{oname}
Version: 1.16.0
Release: 1
Summary: Python 2 and 3 compatibility utilities
URL: https://github.com/benjaminp/six
Source0: %{url}/archive/%{version}/%{oname}-%{version}.tar.gz
License: MIT
Group: Development/Python
BuildArch: noarch
BuildRequires: pkgconfig(python)
BuildRequires: pkgconfig(python3)
BuildRequires: pythonegg(setuptools)
BuildRequires: python3egg(setuptools)
BuildRequires: python38-devel
BuildRequires: python38-setuptools
%description
Six is a Python 2 and 3 compatibility library. It provides utility functions
for smoothing over the differences between the Python versions with the goal of
writing Python code that is compatible on both Python versions. See the
documentation for more information on what is provided.
Six supports Python 2.4+.
Online documentation is at http://packages.python.org/six/.
Bugs can be reported to http://bitbucket.org/gutworth/six. The code can also
be found there.
%prep
%setup -qn %{oname}-%{version}
cp -a . %{py3dir}
cp -a . %{py38dir}
#-------------------------------------------------------------------
%package -n python3-%{oname}
Group: Development/Python
%description -n python3-%{oname}
Six is a Python 2 and 3 compatibility library. It provides utility functions
for smoothing over the differences between the Python versions with the goal of
writing Python code that is compatible on both Python versions. See the
documentation for more information on what is provided.
Six supports Python 2.4+.
Online documentation is at http://packages.python.org/six/.
Bugs can be reported to http://bitbucket.org/gutworth/six. The code can also
be found there.
%files -n python3-%{oname}
%doc LICENSE README.rst documentation/index.rst
%{py3_puresitedir}/*
#-------------------------------------------------------------------
%package -n python38-%{oname}
Group: Development/Python
%description -n python38-%{oname}
Six is a Python 2 and 3 compatibility library. It provides utility functions
for smoothing over the differences between the Python versions with the goal of
writing Python code that is compatible on both Python versions. See the
documentation for more information on what is provided.
Six supports Python 2.4+.
Online documentation is at http://packages.python.org/six/.
Bugs can be reported to http://bitbucket.org/gutworth/six. The code can also
be found there.
%files -n python38-%{oname}
%doc LICENSE README.rst documentation/index.rst
%{py38_puresitedir}/*
#-------------------------------------------------------------------
%build
%py_build
pushd %{py3dir}
%py3_build
popd
pushd %{py38dir}
%py38_build
popd
%install
%py_install
pushd %{py3dir}
%py3_install
popd
pushd %{py38dir}
%py38_install
popd
%files
%doc LICENSE README.rst documentation/index.rst
%{py_puresitedir}/*