python-jsonschema/python-jsonschema.spec
2019-10-01 12:03:02 +03:00

44 lines
1.1 KiB
RPMSpec

%define oname jsonschema
Name: python-%{oname}
Version: 3.0.2
Release: 1
Summary: An implementation of JSON Schema validation for Python
Source0: http://pypi.python.org/packages/source/j/jsonschema/jsonschema-%{version}.tar.gz
License: MIT
Group: Development/Python
Url: http://github.com/Julian/jsonschema
BuildArch: noarch
BuildRequires: pkgconfig(python)
BuildRequires: pythonegg(nose)
BuildRequires: pythonegg(mock)
BuildRequires: pythonegg(pyrsistent)
%description
jsonschema is JSON Schema validator currently based on
http://tools.ietf.org/html/draft-zyp-json-schema-03
%prep
%setup -q -n %{oname}-%{version}
# drop bundled egg-info
rm -rf jsonschema.egg-info/
%build
python setup.py build
%install
python setup.py install --root=%{buildroot}
%check
%{_bindir}/nosetests-2* -v || :
%files
%doc CHANGELOG.rst COPYING README.rst
%{_bindir}/jsonschema
%{py_puresitedir}/jsonschema/*.py*
%{py_puresitedir}/jsonschema/tests/*.py*
%{py_puresitedir}/jsonschema*.egg-info
%{py_puresitedir}/jsonschema/schemas/draft*.json
%{py_puresitedir}/jsonschema/benchmarks