mirror of
https://abf.rosa.ru/djam/python-click.git
synced 2025-02-23 17:32:50 +00:00
60 lines
1.9 KiB
RPMSpec
60 lines
1.9 KiB
RPMSpec
%define module click
|
|
|
|
Name: python-%{module}
|
|
Version: 7.1.2
|
|
Release: 1
|
|
Summary: A simple wrapper around optparse for powerful command line utilities
|
|
Group: Development/Python
|
|
License: BSD
|
|
Url: https://palletsprojects.com/p/click/
|
|
Source0: https://pypi.io/packages/source/c/%{module}/%{module}-%{version}.tar.gz
|
|
Provides: python-click == %{EVRD}
|
|
Obsoletes: python3-click == 7.0.dev0
|
|
Obsoletes: python-click == 7.0.dev0
|
|
BuildArch: noarch
|
|
|
|
%description
|
|
Click is a Python package for creating beautiful command line interfaces
|
|
in a composable way with as little code as necessary. It's the "Command
|
|
Line Interface Creation Kit". It's highly configurable but comes with
|
|
sensible defaults out of the box.
|
|
|
|
It aims to make the process of writing command line tools quick and fun
|
|
while also preventing any frustration caused by the inability to
|
|
implement an intended CLI API.
|
|
|
|
#-----------------------------------------------------------------------
|
|
|
|
%package -n python3-%{module}
|
|
Summary: A simple wrapper around optparse for powerful command line utilities
|
|
Group: Development/Python
|
|
|
|
BuildRequires: pkgconfig(python3)
|
|
BuildRequires: python3egg(setuptools)
|
|
|
|
%description -n python3-%{module}
|
|
Click is a Python package for creating beautiful command line interfaces
|
|
in a composable way with as little code as necessary. It's the "Command
|
|
Line Interface Creation Kit". It's highly configurable but comes with
|
|
sensible defaults out of the box.
|
|
|
|
It aims to make the process of writing command line tools quick and fun
|
|
while also preventing any frustration caused by the inability to
|
|
implement an intended CLI API.
|
|
|
|
%files -n python3-%{module}
|
|
%doc *.rst
|
|
%{python3_sitelib}/click/*.py*
|
|
%{python3_sitelib}/click/__pycache__
|
|
%{python3_sitelib}/click*.egg-info
|
|
#----------------------------------------------------------------------
|
|
|
|
%prep
|
|
%setup -qn %{module}-%{version}
|
|
rm -rf %{module}.egg-info
|
|
|
|
%build
|
|
%py3_build
|
|
|
|
%install
|
|
%py3_install
|