python-click/python-click.spec
abfonly fb92e64782 Log: Update to 7.0 stable
build py3 module
spec clean
2018-12-24 15:56:16 +03:00

75 lines
2 KiB
RPMSpec

%define module Click
Name: python-%{module}
Version: 7.0
Release: 2
Summary: A simple wrapper around optparse for powerful command line utilities
Source0: http://pypi.python.org/packages/source/c/%{module}/%{module}-%{version}.tar.gz
License: BSD
Group: Development/Python
Url: https://palletsprojects.com/p/click/
BuildRequires: pythonegg(setuptools)
BuildRequires: pkgconfig(python)
Obsoletes: pythonegg(click) == 7.0.dev0
Obsoletes: python-click == 7.0.dev0
Provides: python-click == %{EVRD}
BuildArch: noarch
%description
Click is a Python package for creating beautiful command line interfaces
in a composable way with as little code as necessary. It's the "Command
Line Interface Creation Kit". It's highly configurable but comes with
sensible defaults out of the box.
It aims to make the process of writing command line tools quick and fun
while also preventing any frustration caused by the inability to
implement an intended CLI API.
%files
%doc docs/ examples/
%{py_puresitedir}/click/*.py*
%{py_puresitedir}/Click*.egg-info
#--------------------------------------------------
%package -n python3-%{module}
Summary: A simple wrapper around optparse for powerful command line utilities
BuildRequires: pkgconfig(python3)
BuildRequires: python3egg(setuptools)
%description -n python3-%{module}
Click is a Python package for creating beautiful command line interfaces
in a composable way with as little code as necessary. It's the "Command
Line Interface Creation Kit". It's highly configurable but comes with
sensible defaults out of the box.
It aims to make the process of writing command line tools quick and fun
while also preventing any frustration caused by the inability to
implement an intended CLI API.
%files -n python3-%{module}
%doc *.rst
%{py3_puresitedir}/click/*.py*
%{py3_puresitedir}/Click*.egg-info
#------------------------------------------
%prep
%setup -qn %{module}-%{version}
rm -rf %{module}.egg-info
cp -a . %{py3dir}
%build
%py2_build
#
pushd %{py3dir}
%py3_build
popd
%install
%py2_install
#
pushd %{py3dir}
%py3_install
popd