python-backports/python-backports.spec
2019-11-06 11:41:38 +03:00

76 lines
2.4 KiB
RPMSpec

%define debug_package %{nil}
%define module backports
Summary: Namespace for backported Python features
Name: python-backports
Version: 1.0
Release: 5
# Only code is sourced from http://www.python.org/dev/peps/pep-0382/
License: Public Domain
Group: Development/Python
URL: https://pypi.python.org/pypi/backports
Source0: backports.py
BuildRequires: pkgconfig(python)
BuildRequires: pkgconfig(python3)
%description
The backports namespace is a namespace reserved for features backported from
the Python standard library to older versions of Python 2.
Packages that exist in the backports namespace in Fedora should not provide
their own backports/__init__.py, but instead require this package.
Backports to earlier versions of Python 3, if they exist, do not need this
package because of changes made in Python 3.3 in PEP 420
(http://www.python.org/dev/peps/pep-0420/).
%files
%{python_sitelib}/backports
%if "%{python_sitelib}" != "%{python_sitearch}"
%{python_sitearch}/backports
%endif
#------------------------------------------------------------------
%package -n python3-%{module}
Group: Development/Python
%description -n python3-%{module}
The backports namespace is a namespace reserved for features backported from
the Python standard library to older versions of Python 2.
Packages that exist in the backports namespace in Fedora should not provide
their own backports/__init__.py, but instead require this package.
Backports to earlier versions of Python 3, if they exist, do not need this
package because of changes made in Python 3.3 in PEP 420
(http://www.python.org/dev/peps/pep-0420/).
%files -n python3-%{module}
%{python3_sitelib}/backports
%if "%{python3_sitelib}" != "%{python3_sitearch}"
%{python3_sitearch}/backports
%endif
#------------------------------------------------------------------
%prep
%build
%install
mkdir -pm 755 %{buildroot}%{python_sitelib}/backports %{buildroot}%{python3_sitelib}/backports
install -pm 644 %{SOURCE0} %{buildroot}%{python_sitelib}/backports/__init__.py
install -pm 644 %{SOURCE0} %{buildroot}%{python3_sitelib}/backports/__init__.py
%if "%{python_sitelib}" != "%{python_sitearch}"
mkdir -pm 755 %{buildroot}%{python_sitearch}/backports
install -pm 644 %{SOURCE0} %{buildroot}%{python_sitearch}/backports/__init__.py
%endif
%if "%{python3_sitelib}" != "%{python3_sitearch}"
mkdir -pm 755 %{buildroot}%{python3_sitearch}/backports
install -pm 644 %{SOURCE0} %{buildroot}%{python3_sitearch}/backports/__init__.py
%endif