podman-compose/podman-compose.spec
Your Name 7fb136b6e2
Some checks failed
Run CI/CD... / main (push) Failing after 21s
1.3.0
2025-02-15 13:46:21 +00:00

63 lines
1.8 KiB
RPMSpec

%global commit ae3deb19dcce2a365eb54f05016de87a65cce43a
%global shortcommit %(c=%{commit}; echo ${c:0:7})
Name: podman-compose
Version: 1.3.0
Release: 1
Summary: Run docker-compose.yml using podman
Group: Development/Python
License: GPLv2
URL: https://github.com/containers/podman-compose
Source0: %{url}/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
#iSource0: https://github.com/containers/podman-compose/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
#BuildRequires: python3-devel
#BuildRequires: python3-setuptools
#BuildRequires: python3-pyyaml
BuildRequires: python38-devel
BuildRequires: python38-setuptools
BuildRequires: python38-pyyaml
#Requires: python3
#Requires: python3-pyyaml
Requires: podman
BuildArch: noarch
%description
An implementation of docker-compose with podman backend.
The main objective of this project is to be able to run
docker-compose.yml unmodified and rootless.
#package -n %{name}-py3
#description -n %{name}-py3
#An implementation of docker-compose with podman backend.
#The main objective of this project is to be able to run
#docker-compose.yml unmodified and rootless.
#files -n %{name}-py3
#{_bindir}/podman-compose3
#{python3_sitelib}/__pycache__/podman_compose*pyc
#{python3_sitelib}/podman_compose*
%files
%doc README.md CONTRIBUTING.md docs/ examples LICENSE
%{_bindir}/podman-compose
%{python38_sitelib}/__pycache__/podman_compose*pyc
%{python38_sitelib}/podman_compose*
#---------------------------------------------------------------
%prep
%setup -q
%build
#py3_build
%py38_build
%install
#py3_install
%py38_install
#Drop spurious shebang
#sed -i /python3/d %{buildroot}%{python3_sitelib}/podman_compose.py
sed -i /python3/d %{buildroot}%{python38_sitelib}/podman_compose.py