magnetcoin/magnetcoin.spec

75 lines
1.6 KiB
RPMSpec

%define oname MagnetCoin
Name: magnetcoin
Version: 1.3.0.1
Release: 1
Summary: MagnetCoin
License: MIT
Group: Office
URL: https://github.com/sergeynors/MagnetCoin
Source0: %{oname}-master.zip
Patch0: %{name}_db.patch
BuildRequires: db52-devel
%description
MagnetCoin peer-to-peer network based digital currency - daemon
MagnetCoin is a free open source peer-to-peer electronic cash system that
is completely decentralized, without the need for a central server or
trusted parties. Users hold the crypto keys to their own money and
transact directly with each other, with the help of a P2P network to
check for double-spending.
By default connects to an IRC network to discover other peers.
Full transaction history is stored locally at each client. This
requires 2+ GB of space, slowly growing.
This package provides MagnetCoind, a combined daemon and CLI tool to
interact with the daemon.
%package daemon
Summary: MagnetCoin daemon
%description daemon
MagnetCoin peer-to-peer network based digital currency - daemon
%files daemon
%{_bindir}/%{name}d
%package qt
Summary: MagnetCoin wallet GUI
%description qt
MagnetCoin peer-to-peer network based digital currency - GUI
%files qt
%{_bindir}/%{name}-qt
%prep
%setup -q -n %{oname}-master
%patch -p0
%build
pushd src
make -f makefile.unix
popd
pushd src/leveldb
chmod +x ./build_detect_platform
popd
qmake MagnetCoin-qt.pro USE_QRCODE=1
make
%install
install -d %{buildroot}%{_bindir}
pushd src
install -Dm0755 %{oname}d %{buildroot}%{_bindir}/%{name}d
popd
install -Dm0755 %{oname}-qt %{buildroot}%{_bindir}/%{name}-qt
%files
%doc README