livecd-tools/livecd-tools.spec
2024-06-09 09:23:51 +00:00

113 lines
3.4 KiB
RPMSpec

%define debug_package %{nil}
Summary: Tools for building live CDs
Name: livecd-tools
Version: 21.1
Release: 66
Epoch: 1
License: GPLv2+
Group: System/Base
URL: https://github.com/livecd-tools/livecd-tools
#Source0: http://fedorahosted.org/releases/l/i/livecd/%{name}-%{version}.tar.bz2
Source0: %{url}/archive/%{name}-%{version}/%{name}-%{version}.tar.gz
Source1: arch.py
Source3: rosa-image-fix-x86.pl
Source4: urpmi-bootstrapper.sh
Patch0: livecd-tools-21.1.urpmi.patch
Patch1: livecd-tools-21.1.split.install.patch
Patch2: livecd-tools-21.1.efi.fixes.patch
Patch3: livecd-tools-21.1.hack.patch
Patch4: livecd-tools-21.1.hack2.patch
Patch5: livecd-tools-21.1.hack3.patch
Patch7: livecd-tools-21.1.no.mac.img.patch
Patch8: livecd-tools-21.1.isolinux.plymouth.fixes.patch
Patch9: livecd-tools-21.1.efi.grub.cfg.patch
Patch10: livecd-tools-21.1.pkg.installation.fix.patch
Patch11: livecd-tools-21.1.drop.initramfs.patch
Patch12: livecd-tools-21.1.efi.no.dm.luks.patch
Patch13: livecd-tools-21.1.basic.graphics.mode.fixed.patch
Patch14: livecd-tools-21.1.shim.efi.renamed.patch
Patch15: livecd-tools-21.1.secureboot.unsigned.kernel.patch
Patch17: livecd-tools-21.1.efi.grub.cfg.echo.patch
Patch18: livecd-tools-21.1.fixed.boot.menu.os.name.patch
Patch19: livecd-tools-21.1.support.efi32.patch
Patch21: livecd-tools-21.1.use.add_drivers.patch
Patch22: livecd-tools-21.1.no.vga.opts.patch
Patch23: livecd-tools-21.1-genisoimage.patch
Patch24: 0001-Run-setfiles-after-chroot.patch
Patch25: 0002-Get-system-architecture-by-bin-sh-executable-instead.patch
Patch27: 0004-hack-use-bash-x-for-post-scripts.patch
BuildArch: noarch
Requires: python-imgcreate = %{EVRD}
Requires: dosfstools
Requires: dumpet
Requires: e2fsprogs
Requires: cdrkit-genisoimage
Requires: isomd5sum
Requires: lorax >= 18.3
Requires: parted
Requires: pyparted
Requires: util-linux
%ifarch %{ix86} x86_64
Requires: syslinux
%endif
%description
Tools for generating live CDs on Fedora based systems including
derived distributions such as RHEL, CentOS and others. See
http://fedoraproject.org/wiki/FedoraLiveCD for more details.
%files
%doc config/livecd-fedora-minimal.ks
%{_mandir}/man*/*
%{_bindir}/livecd-creator
%{_bindir}/livecd-iso-to-disk
%{_bindir}/livecd-iso-to-pxeboot
%{_bindir}/image-creator
%{_bindir}/liveimage-mount
%{_bindir}/edit-livecd
%{_bindir}/mkbiarch
%{_bindir}/rosa-image-fix-x86.pl
%{_sbindir}/livecd-urpmi-bootstrapper
#----------------------------------------------------------------------------
%package -n python-imgcreate
Summary: Python modules for building system images
Group: System/Base
Requires: coreutils
Requires: dosfstools >= 2.11-8
Requires: e2fsprogs
Requires: pykickstart >= 0.96
Requires: python-dbus
Requires: python-selinux
Requires: python-urlgrabber
Requires: squashfs-tools
Requires: util-linux
%description -n python-imgcreate
Python modules that can be used for building images for things
like live image or appliances.
%files -n python-imgcreate
%dir %{python_sitelib}/imgcreate
%{python_sitelib}/imgcreate/*.py*
#----------------------------------------------------------------------------
%prep
%setup -qn %{name}-%{name}-%{version}
%apply_patches
%build
make
%install
%makeinstall_std
install -m 0644 %{SOURCE1} %{buildroot}%{python_sitelib}/imgcreate/
install -m 0755 %{SOURCE3} %{buildroot}%{_bindir}/
mkdir -p %{buildroot}%{_sbindir}/
install -m 0755 %{SOURCE4} %{buildroot}%{_sbindir}/livecd-urpmi-bootstrapper