libzrtpcpp/libzrtpcpp.spec
2017-02-17 10:53:13 +03:00

76 lines
2.2 KiB
RPMSpec

%define major 4
%define libname %mklibname zrtpcpp %{major}
%define devname %mklibname zrtpcpp -d
Summary: A ccrtp extension for zrtp/Zfone support
Name: libzrtpcpp
Version: 4.6.4
Release: 3
License: GPLv2+
Group: System/Libraries
Url: http://www.gnu.org/software/commoncpp/commoncpp.html
Source0: ftp://ftp.gnu.org/gnu/ccrtp/libzrtpcpp-%{version}.tar.gz
Patch0: libzrtpcpp-4.4.0-no-warning.patch
Patch1: libzrtpcpp-4.6.4_deprecated.patch
BuildRequires: cmake
BuildRequires: stdc++-devel
BuildRequires: pkgconfig(libccrtp)
BuildRequires: pkgconfig(libgcrypt)
%description
This library is a GPL licensed extension to the GNU RTP Stack, ccrtp, that
offers compatibility with Phil Zimmermann's zrtp/Zfone voice encryption, and
which can be directly embedded into telephony applications. The current
release is based on a beta draft of the zrtp spec.
#----------------------------------------------------------------------------
%package -n %{libname}
Summary: Abstract asynchronous event notification library
Group: System/Libraries
%description -n %{libname}
This library is a GPL licensed extension to the GNU RTP Stack, ccrtp, that
offers compatibility with Phil Zimmermann's zrtp/Zfone voice encryption, and
which can be directly embedded into telephony applications. The current
release is based on a beta draft of the zrtp spec.
%files -n %{libname}
%{_libdir}/libzrtpcpp.so.%{major}*
#----------------------------------------------------------------------------
%package -n %{devname}
Summary: Development library and header files for the libzrtpcpp library
Group: Development/C
Requires: %{libname} = %{EVRD}
Provides: %{name}-devel = %{EVRD}
%description -n %{devname}
This package provides the header files, link libraries, and documentation for
building applications that use libzrtpcpp.
%files -n %{devname}
%doc AUTHORS COPYING
%dir %{_includedir}/libzrtpcpp
%dir %{_includedir}/libzrtpcpp/common
%{_includedir}/libzrtpcpp/*.h
%{_includedir}/libzrtpcpp/common/osSpecifics.h
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
#----------------------------------------------------------------------------
%prep
%setup -qn ZRTPCPP-%{version}
%patch0 -p1
%patch1 -p1
%build
%cmake \
-DCCRTP:BOOL=ON
%make
%install
%makeinstall_std -C build