libsodium/libsodium.spec
Your Name f9f372fd44
Some checks failed
Run CI/CD... / main (push) Failing after 2m31s
1.0.20
2025-02-02 10:48:00 +00:00

80 lines
2.7 KiB
RPMSpec

%define major 26
%define libname %mklibname sodium %{major}
%define devname %mklibname sodium -d
Name: libsodium
Version: 1.0.20
Release: 1
Group: System/Libraries
Summary: The Sodium crypto library
License: ISC
URL: https://libsodium.org
Source0: https://download.libsodium.org/libsodium/releases/%{name}-%{version}.tar.gz
%description
Sodium is a new, easy-to-use software library for encryption, decryption,
signatures, password hashing and more. It is a portable, cross-compilable,
installable, packageable fork of NaCl, with a compatible API, and an extended
API to improve usability even further. Its goal is to provide all of the core
operations needed to build higher-level cryptographic tools. The design
choices emphasize security, and "magic constants" have clear rationales.
The same cannot be said of NIST curves, where the specific origins of certain
constants are not described by the standards. And despite the emphasis on
higher security, primitives are faster across-the-board than most
implementations of the NIST standards.
%package -n %{libname}
Summary: The Sodium crypto library
Group: System/Libraries
%description -n %{libname}
Sodium is a new, easy-to-use software library for encryption, decryption,
signatures, password hashing and more. It is a portable, cross-compilable,
installable, packageable fork of NaCl, with a compatible API, and an extended
API to improve usability even further. Its goal is to provide all of the core
operations needed to build higher-level cryptographic tools. The design
choices emphasize security, and "magic constants" have clear rationales.
The same cannot be said of NIST curves, where the specific origins of certain
constants are not described by the standards. And despite the emphasis on
higher security, primitives are faster across-the-board than most
implementations of the NIST standards.
%package -n %{devname}
Summary: Development related files of %{name}
Group: Development/C
Provides: %{name}-devel = %{version}-%{release}
Requires: %{libname} = %{EVRD}
%description -n %{devname}
This package contains headers and other necessary files to develop.
or compile applications that use %{name}.
%prep
%setup -q
%build
%configure2_5x \
--disable-static \
--disable-silent-rules
%make
%install
%makeinstall_std
%check
make check
%files -n %{libname}
%doc LICENSE
%{_libdir}/libsodium.so.%{major}*
%files -n %{devname}
%doc AUTHORS ChangeLog README.markdown THANKS
%doc test/default/*.{c,h}
%{_includedir}/sodium.h
%{_includedir}/sodium/
%{_libdir}/libsodium.so
%{_libdir}/pkgconfig/libsodium.pc