mirror of
https://abf.rosa.ru/djam/libprojectm.git
synced 2025-02-23 18:22:51 +00:00
97 lines
2.6 KiB
RPMSpec
97 lines
2.6 KiB
RPMSpec
%define oname libprojectM
|
|
%define major 3
|
|
%define libname %mklibname projectm %{major}
|
|
%define devname %mklibname projectm -d
|
|
|
|
Summary: Visualization library for OpenGL based on Milkdrop
|
|
Name: libprojectm
|
|
Epoch: 1
|
|
Version: 3.1.12
|
|
Release: 1
|
|
License: LGPLv2.1+
|
|
Group: System/Libraries
|
|
Url: https://github.com/projectM-visualizer
|
|
Source0: https://github.com/projectM-visualizer/projectm/archive/v%{version}.tar.gz
|
|
|
|
BuildRequires: gomp-devel
|
|
BuildRequires: qt5-devel
|
|
BuildRequires: pkgconfig(ftgl)
|
|
BuildRequires: pkgconfig(sdl2)
|
|
BuildRequires: pkgconfig(jack)
|
|
BuildRequires: pkgconfig(glew)
|
|
BuildRequires: pkgconfig(libpulse)
|
|
|
|
%description
|
|
projectM is a reimplementation of Milkdrop under OpenGL.
|
|
|
|
%files
|
|
%{_bindir}/projectM-jack
|
|
%{_bindir}/projectM-pulseaudio
|
|
%{_bindir}/projectM-unittest
|
|
%{_bindir}/projectMSDL
|
|
%{_datadir}/applications/projectM-jack.desktop
|
|
%{_datadir}/applications/projectM-pulseaudio.desktop
|
|
%{_datadir}/icons/hicolor/scalable/apps/projectM.svg
|
|
%{_mandir}/man1/projectM-jack.1.*
|
|
%{_mandir}/man1/projectM-pulseaudio.1.*
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%package data
|
|
Summary: Visualization library for OpenGL based on Milkdrop
|
|
Group: Graphics
|
|
Requires: fonts-ttf-bitstream-vera
|
|
|
|
%description data
|
|
projectM is a reimplementation of Milkdrop under OpenGL. This contains data
|
|
files and presets.
|
|
|
|
%files data
|
|
%{_datadir}/projectM/
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%package -n %{libname}
|
|
Summary: Visualization library for OpenGL based on Milkdrop
|
|
Group: System/Libraries
|
|
Requires: %{name}-data >= %{EVRD}
|
|
|
|
%description -n %{libname}
|
|
projectM is a reimplementation of Milkdrop under OpenGL.
|
|
|
|
%files -n %{libname}
|
|
%{_libdir}/libprojectM.so.%{major}*
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%package -n %{devname}
|
|
Summary: Visualization library for OpenGL based on Milkdrop
|
|
Group: Development/C
|
|
Requires: %{libname} = %{EVRD}
|
|
Provides: libprojectm-devel = %{EVRD}
|
|
|
|
%description -n %{devname}
|
|
projectM is a reimplementation of Milkdrop under OpenGL.
|
|
|
|
%files -n %{devname}
|
|
%{_includedir}/libprojectM
|
|
%{_libdir}/libprojectM.so
|
|
%{_libdir}/pkgconfig/*.pc
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%prep
|
|
%setup -qn projectm-%{version}
|
|
%autopatch -p1
|
|
|
|
%build
|
|
export LDFLAGS="%{ldflags} -lpthread"
|
|
autoreconf -fiv
|
|
%configure --enable-gles --enable-sdl --enable-threading --enable-qt
|
|
%make_build
|
|
|
|
%install
|
|
%make_install
|
|
|
|
#replace by symlink
|
|
ln -sf %{_datadir}/fonts/TTF/{Vera.ttf,VeraMono.ttf} %{buildroot}%{_datadir}/projectM/fonts/
|