mirror of
https://abf.rosa.ru/djam/liblzo.git
synced 2025-02-23 13:32:46 +00:00
87 lines
2.5 KiB
RPMSpec
87 lines
2.5 KiB
RPMSpec
%define oname lzo
|
|
%define major 2
|
|
%define apiver 2
|
|
%define libname %mklibname lzo %{apiver} %{major}
|
|
%define devname %mklibname lzo -d
|
|
|
|
Summary: Data compression library with very fast (de-)compression
|
|
Name: liblzo
|
|
Version: 2.10
|
|
Release: 1
|
|
License: GPLv2+
|
|
Group: System/Libraries
|
|
Url: http://www.oberhumer.com/opensource/lzo/
|
|
Source0: http://www.oberhumer.com/opensource/lzo/download/%{oname}-%{version}.tar.gz
|
|
|
|
%description
|
|
LZO is a portable lossless data compression library written in ANSI C.
|
|
It offers pretty fast compression and *very* fast decompression.
|
|
Decompression requires no memory. In addition there are slower
|
|
compression levels achieving a quite competitive compression ratio while
|
|
still decompressing at this very high speed.
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%package -n %{libname}
|
|
Summary: Data compression library with very fast (de-)compression
|
|
Group: System/Libraries
|
|
|
|
%description -n %{libname}
|
|
LZO is a portable lossless data compression library written in ANSI C.
|
|
It offers pretty fast compression and *very* fast decompression.
|
|
Decompression requires no memory. In addition there are slower
|
|
compression levels achieving a quite competitive compression ratio while
|
|
still decompressing at this very high speed.
|
|
|
|
%files -n %{libname}
|
|
%doc AUTHORS NEWS README THANKS doc/LZO.TXT doc/LZO.FAQ
|
|
%{_libdir}/liblzo%{apiver}.so.%{major}*
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%package -n %{devname}
|
|
Summary: Headers files of liblzo library
|
|
Group: Development/C
|
|
Requires: %{libname} = %{EVRD}
|
|
Provides: %{name}2-devel = %{EVRD}
|
|
Provides: %{name}-devel = %{EVRD}
|
|
|
|
%description -n %{devname}
|
|
LZO is a portable lossless data compression library written in ANSI C.
|
|
It offers pretty fast compression and *very* fast decompression.
|
|
Decompression requires no memory. In addition there are slower
|
|
compression levels achieving a quite competitive compression ratio while
|
|
still decompressing at this very high speed.
|
|
|
|
%files -n %{devname}
|
|
%doc doc/LZOAPI.TXT doc/LZOTEST.TXT
|
|
%{_bindir}/lzotest
|
|
%{_libdir}/*.a
|
|
%{_libdir}/pkgconfig/lzo2.pc
|
|
%{_libdir}/*.so
|
|
%{_includedir}/*
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%prep
|
|
%setup -qn %{oname}-%{version}
|
|
|
|
%build
|
|
export CONFIGURE_TOP=`pwd`
|
|
|
|
mkdir -p shared
|
|
cd shared
|
|
%configure2_5x --enable-shared
|
|
%make
|
|
cd ..
|
|
|
|
%install
|
|
|
|
%makeinstall_std -C shared
|
|
install -m755 shared/lzotest/lzotest -D %{buildroot}%{_bindir}/lzotest
|
|
rm -rf %{buildroot}%{_datadir}/doc/lzo
|
|
|
|
%check
|
|
cd shared
|
|
make check
|
|
make test
|