mirror of
https://abf.rosa.ru/djam/kubescape.git
synced 2025-02-22 22:32:54 +00:00
44 lines
1.1 KiB
RPMSpec
44 lines
1.1 KiB
RPMSpec
%define debug %nil
|
|
%define debug_package %nil
|
|
%define git2go_rev eae00773cce87d5282a8ac7c10b5c1961ee6f9cb
|
|
|
|
Name: kubescape
|
|
Version: 3.0.29
|
|
Release: 1
|
|
Summary: NSA and CISA kubernetes securely tests
|
|
URL: https://github.com/armosec/kubescape
|
|
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
|
#Source1: https://github.com/libgit2/git2go/archive/%{git2go_rev}/git2go-%{git2go_rev}.tar.gz
|
|
License: ASL 2.0
|
|
Group: Development/Other
|
|
BuildRequires: go >= 1.11
|
|
BuildRequires: git-core
|
|
BuildRequires: upx
|
|
BuildRequires: pkgconfig(openssl3.3)
|
|
|
|
%description
|
|
Kubescape is the first tool for testing if Kubernetes
|
|
is deployed securely as defined in Kubernetes Hardening
|
|
Guidance by to NSA and CISA Tests are configured with
|
|
YAML files, making this tool easy to update as test
|
|
specifications evolve.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
#tar -xf %{SOURCE1}
|
|
#cp -a git2go-%{git2go_rev}/* git2go/
|
|
|
|
%build
|
|
export GOPROXY=https://proxy.golang.org/cached-only
|
|
go mod tidy
|
|
go build --ldflags="-s -w" -o %{name} .
|
|
|
|
upx %{name}
|
|
|
|
%install
|
|
install -Dm0755 %{name} %{buildroot}%{_bindir}/%{name}
|
|
|
|
%files
|
|
%doc README.md LICENSE
|
|
%{_bindir}/%{name}
|