mirror of
https://abf.rosa.ru/djam/k9s.git
synced 2025-02-22 17:32:56 +00:00
40 lines
976 B
RPMSpec
40 lines
976 B
RPMSpec
%define debug %nil
|
|
%define debug_package %nil
|
|
|
|
Name: k9s
|
|
Version: 0.40.5
|
|
Release: 1
|
|
Summary: Kubernetes CLI To Manage Your Clusters In Style
|
|
URL: https://k9scli.io
|
|
Source0: https://github.com/derailed/k9s/archive/v%{version}/%{name}-%{version}.tar.gz
|
|
License: ASL 2.0
|
|
Group: Development/Other
|
|
BuildRequires: go >= 1.11
|
|
BuildRequires: upx
|
|
BuildRequires: git-core
|
|
BuildRequires: pkgconfig(x11)
|
|
BuildRequires: pkgconfig(openssl3.3)
|
|
|
|
%description
|
|
K9s provides a terminal UI to interact with your Kubernetes
|
|
clusters. The aim of this project is to make it easier to
|
|
navigate, observe and manage your applications in the wild.
|
|
K9s continually watches Kubernetes for changes and offers
|
|
subsequent commands to interact with your observed
|
|
resources.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
export GOPROXY=https://proxy.golang.org/cached-only
|
|
%make build
|
|
upx execs/%{name}
|
|
|
|
%install
|
|
install -Dm0755 execs/%{name} %{buildroot}/%{_bindir}/%{name}
|
|
|
|
%files
|
|
%doc README.md LICENSE
|
|
%{_bindir}/%{name}
|
|
|