hysteria/hysteria.spec
Your Name 6ccc8d9485
All checks were successful
Run CI/CD... / main (push) Successful in 8m3s
2.6.1
2025-02-04 20:54:44 +00:00

73 lines
2 KiB
RPMSpec

%define debug %nil
%define debug_package %nil
Name: hysteria
Version: 2.6.1
Release: 1
Summary: A powerful, lightning fast and censorship resistant proxy
URL: https://v2.hysteria.network
Source0: https://github.com/apernet/hysteria/archive/app%2Fv%{version}/%{name}-%{version}.tar.gz
License: MIT
Group: Development/Other
BuildRequires: go
BuildRequires: git-core
BuildRequires: upx
BuildRequires: pkgconfig(openssl3.3)
%description
Hysteria is a powerful, lightning fast and censorship
resistant proxy.
Packed to the gills
Expansive range of modes including SOCKS5, HTTP proxy,
TCP/UDP forwarding, Linux TProxy - not to mention
additional features continually being added.
Lightning fast
Powered by a custom QUIC protocol, Hysteria delivers
unparalleled performance over even the most unreliable
and lossy networks.
Censorship resistant
Our protocol is designed to masquerade as standard HTTP/3
traffic, making it very difficult to detect and block
without widespread collateral damage.
Cross-platform
We have builds for all major platforms and architectures.
Deploy anywhere & use everywhere.
Easy integration
With built-in support for custom authentication, traffic
statistics & access control, Hysteria is easy to integrate
into your infrastructure.
Open standards
We have well-documented specifications and code for developers
to contribute and build their own apps.
%prep
%setup -qn %{name}-app-v%{version}
%build
export GOPROXY="https://goproxy.io,direct"
go build -ldflags="-s -w \
-X github.com/apernet/hysteria/app/cmd.appVersion=%{version} \
-X github.com/apernet/hysteria/app/cmd.appDate=$(date +%Y-%m-%dT%H:%M:%SZ) \
-X github.com/apernet/hysteria/app/cmd.appType=release \
-X github.com/apernet/hysteria/app/cmd.appPlatform=%{vendor} \
-X github.com/apernet/hysteria/app/cmd.appArch=$(uname -i) " -o bin/%{name} ./app
upx bin/*
%install
install -Dm0755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%files
%doc README.md LICENSE.md PROTOCOL.md
%{_bindir}/%{name}