hugo/hugo.spec
2024-09-10 15:24:51 +00:00

35 lines
724 B
RPMSpec

%define debug %nil
%define debug_package %nil
Name: hugo
Version: 0.134.2
Release: 1
Summary: A framework for building websites
URL: https://gohugo.io
Source0: https://github.com/gohugoio/hugo/archive/v%{version}/%{name}-%{version}.tar.gz
License: MIT
Group: Development/Other
BuildRequires: go
BuildRequires: git-core
BuildRequires: upx
%description
A fast and flexible static site generator built with love by
bep, spf13, and friends in Go.
%prep
%setup -q
%build
export GOPROXY=https://proxy.golang.org/cached-only
CGO_ENABLED=1 go build -ldflags '-s -w' -o ./bin/%{name} .
upx bin/%{name}
%install
install -Dm0755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%files
%doc README.md LICENSE
%{_bindir}/%{name}