helmfile/helmfile.spec
Your Name 964c8b0279
All checks were successful
Run CI/CD... / main (push) Successful in 36m59s
0.154.0
2025-02-13 21:26:13 +00:00

37 lines
844 B
RPMSpec

%define debug %nil
%define debug_package %nil
Name: helmfile
Version: 0.154.0
Release: 1
Summary: Deploy Kubernetes Helm Charts
URL: https://helmfile.readthedocs.io
Source0: https://github.com/helmfile/helmfile/archive/v%{version}/%{name}-%{version}.tar.gz
License: MIT
Group: Development/Other
BuildRequires: go
BuildRequires: git-core
BuildRequires: upx
%description
Declaratively deploy your Kubernetes manifests, Kustomize
configs, and Charts as Helm releases. Generate all-in-one
manifests for use with ArgoCD.
%prep
%setup -q
%build
export GOPROXY=direct
go build -o bin/%{name} -ldflags="-s -w -X go.szostok.io/version.version=%{version}" .
upx bin/%{name}
%install
install -Dm0755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%files
%doc README* LICENSE CONTRIBUTING.md SECURITY.md USERS.md docs examples
%{_bindir}/%{name}