helm/helm.spec
2024-04-11 07:42:49 +00:00

38 lines
815 B
RPMSpec

%define debug %nil
%define debug_package %nil
Name: helm
Version: 3.14.4
Release: 1
Summary: The Kubernetes Package Manager
URL: https://helm.sh
Source0: https://github.com/helm/helm/archive/v%{version}/%{name}-%{version}.tar.gz
License: ASL 2.0
Group: Development/Other
BuildRequires: go
BuildRequires: git-core
BuildRequires: upx
%description
Helm is a tool for managing Charts. Charts are packages
of pre-configured Kubernetes resources.
%prep
%setup -q
%build
export GOPROXY=direct
%make
upx bin/%{name}
%install
install -Dm0755 bin/%{name} %{buildroot}%{_bindir}/%{name}
install -d %{buildroot}%{_sysconfdir}/bash_completion.d
bin/helm completion bash > %{buildroot}%{_sysconfdir}/bash_completion.d/%{name}
%files
%doc README.md LICENSE
%{_bindir}/%{name}
%{_sysconfdir}/bash_completion.d/%{name}