handbrake/handbrake.spec
2014-10-12 05:50:34 +04:00

88 lines
2.5 KiB
RPMSpec

%define _enable_debug_packages %{nil}
%define debug_package %{nil}
%define lname HandBrake
Summary: MPEG-AVC(H.264)/MPEG-4 converter
Name: handbrake
Version: 0.9.9
Release: 6
License: GPLv2+
Group: Video
Url: http://handbrake.fr/
Source0: %{lname}-%{version}.tar.bz2
Source1: HandBrake_po.tar.gz
Patch0: HandBrake-0.9.9-fixghb.patch
BuildRequires: intltool
BuildRequires: iso-codes
BuildRequires: libtool
BuildRequires: svn
BuildRequires: valgrind
BuildRequires: yasm
BuildRequires: bzip2-devel
BuildRequires: pkgconfig(gstreamer-plugins-base-0.10)
BuildRequires: pkgconfig(theora)
BuildRequires: pkgconfig(libgtkhtml-3.14)
BuildRequires: pkgconfig(libnotify)
BuildRequires: pkgconfig(gstreamer-0.10)
BuildRequires: pkgconfig(webkit-1.0)
BuildRequires: pkgconfig(gudev-1.0)
BuildRequires: pkgconfig(libass)
BuildRequires: pkgconfig(vorbis)
BuildRequires: pkgconfig(samplerate)
BuildRequires: pkgconfig(zlib)
%description
HandBrake is an open-source, GPL-licensed, multi-platform,
multi-threaded MPEG-AVC(x.264)/MPEG-4 converter, available for
MacOS X, Linux and Windows. It is a video encoder that takes
your movies and transfers them to a format that's useful on
your computers, media centers, and portable electronic devices.
%files
%doc AUTHORS COPYING CREDITS NEWS THANKS TRANSLATIONS
%{_bindir}/*
%{_datadir}/applications/*
%{_datadir}/icons/hicolor/*/apps/hb-icon.png
%{_datadir}/locale/ru/LC_MESSAGES/ghb.mo
%{_datadir}/locale/cs/LC_MESSAGES/ghb.mo
#----------------------------------------------------------------------------
%prep
%setup -q -n %{lname}-%{version}
%patch0 -p1
cd gtk/
tar -xvzf %{SOURCE1}
find . -name "Makefile*" -o -name "*.m4" |xargs sed -i -e 's,configure.in,configure.ac,g'
%build
# export CFLAGS="$RPM_OPT_FLAGS"
# export CXXFLAGS="$RPM_OPT_FLAGS"
./configure --prefix=%{_prefix} --launch --launch-jobs=0 --enable-ff-mpeg2
pushd gtk
autoreconf
popd
cd build && make
%install
%makeinstall_std -C build
%find_lang ghb
install -m 0755 build/HandBrakeCLI %{buildroot}%{_bindir}/HandBrakeCLI
pushd %{buildroot}%{_bindir}
ln -s ./HandBrakeCLI ./handbrake
popd
sed -i -e "s|hb-icon|hb-icon.png|" %{buildroot}%{_datadir}/applications/ghb.desktop
desktop-file-install --vendor="" \
--remove-category="Application" \
--add-category="X-MandrivaLinux-Multimedia-Video" \
--add-category="X-MandrivaLinux-CrossDesktop" \
--dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/*
rm -rf %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache