mirror of
https://abf.rosa.ru/djam/handbrake.git
synced 2025-02-24 01:02:50 +00:00
130 lines
3.5 KiB
RPMSpec
130 lines
3.5 KiB
RPMSpec
%define distsuffix plf
|
|
|
|
%define _enable_debug_packages %{nil}
|
|
%define debug_package %{nil}
|
|
|
|
%define gstapi 1.0
|
|
%define oname HandBrake
|
|
|
|
Summary: MPEG-AVC(H.264)/MPEG-4 converter
|
|
Name: handbrake
|
|
Version: 1.2.0
|
|
Release: 5
|
|
License: GPLv2+
|
|
Group: Video
|
|
Url: http://handbrake.fr/
|
|
Source0: %{oname}-%{version}-source.tar.bz2
|
|
Source1: handbrake-1.2.0_ru.tar.gz
|
|
# force using system libraries, some from Source2 will not bee needed
|
|
Patch0: ROSA-force-system-libs.patch
|
|
# additional libraries
|
|
Source2: download.tar.gz
|
|
BuildRequires: cmake
|
|
BuildRequires: intltool
|
|
BuildRequires: iso-codes
|
|
BuildRequires: libtool
|
|
BuildRequires: nasm
|
|
BuildRequires: svn
|
|
BuildRequires: valgrind
|
|
BuildRequires: yasm
|
|
BuildRequires: bzip2-devel
|
|
BuildRequires: ffmpeg-devel
|
|
BuildRequires: jansson-devel
|
|
BuildRequires: liblame-devel
|
|
BuildRequires: pkgconfig(gstreamer-%{gstapi})
|
|
BuildRequires: pkgconfig(gstreamer-plugins-base-%{gstapi})
|
|
BuildRequires: pkgconfig(gthread-2.0)
|
|
BuildRequires: pkgconfig(gtk+-3.0)
|
|
BuildRequires: pkgconfig(gudev-1.0)
|
|
BuildRequires: pkgconfig(libass)
|
|
BuildRequires: pkgconfig(libgtkhtml-3.14)
|
|
BuildRequires: pkgconfig(libnotify)
|
|
BuildRequires: pkgconfig(samplerate)
|
|
BuildRequires: pkgconfig(theora)
|
|
BuildRequires: pkgconfig(vorbis)
|
|
BuildRequires: pkgconfig(webkit-1.0)
|
|
BuildRequires: pkgconfig(webkitgtk-3.0)
|
|
BuildRequires: pkgconfig(x264)
|
|
BuildRequires: pkgconfig(x265)
|
|
BuildRequires: pkgconfig(vpx)
|
|
BuildRequires: pkgconfig(dvdread)
|
|
BuildRequires: pkgconfig(dvdnav)
|
|
# we should switch to system libbluray in rosa2019.1
|
|
# and update ROSA-force-system-libs.patch
|
|
%if %{mdvver} >= 201800
|
|
BuildRequires: pkgconfig(libbluray) >= 1.0
|
|
%endif
|
|
BuildRequires: pkgconfig(fdk-aac)
|
|
BuildRequires: pkgconfig(libva)
|
|
BuildRequires: pkgconfig(libva-drm)
|
|
BuildRequires: pkgconfig(zlib)
|
|
BuildRequires: liblzma-devel
|
|
BuildRequires: ffnvcodec-headers
|
|
Suggests: typelib(AppIndicator3)
|
|
Suggests: gstreamer%{gstapi}-libav
|
|
Suggests: gstreamer%{gstapi}-plugins-base
|
|
Suggests: gstreamer%{gstapi}-plugins-good
|
|
Suggests: gstreamer%{gstapi}-plugins-bad
|
|
Suggests: gstreamer%{gstapi}-plugins-ugly
|
|
Suggests: gstreamer%{gstapi}-pulse
|
|
|
|
%description
|
|
HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded
|
|
MPEG-AVC(x.264)/MPEG-4 converter, available for MacOS X, Linux and Windows.
|
|
It is a video encoder that takes your movies and transfers them to a format
|
|
that's useful on your computers, media centers, and portable electronic
|
|
devices.
|
|
|
|
%files -f ghb.lang
|
|
%doc COPYING
|
|
%{_bindir}/*
|
|
%{_datadir}/applications/*
|
|
%{_datadir}/icons/hicolor/scalable/apps/hb-icon.svg
|
|
%{_datadir}/icons/hicolor/scalable/apps/fr.handbrake.ghb.svg
|
|
%{_datadir}/metainfo/fr.handbrake.ghb.appdata.xml
|
|
#{_datadir}/locale/*/LC_MESSAGES/ghb.mo
|
|
|
|
#----------------------------------------------------------------------------
|
|
|
|
%prep
|
|
%setup -qn %{oname}-%{version}
|
|
%patch0 -p1
|
|
|
|
tar -xvzf %{SOURCE2}
|
|
|
|
pushd gtk/po
|
|
tar -xvzf %{SOURCE1}
|
|
popd
|
|
|
|
%build
|
|
bash ./configure \
|
|
--prefix=%{_prefix} \
|
|
--launch --launch-jobs=0 \
|
|
--enable-x265 \
|
|
--enable-fdk-aac \
|
|
--enable-qsv
|
|
|
|
pushd gtk
|
|
intltoolize -f
|
|
autoreconf -fi
|
|
popd
|
|
cd build && make
|
|
|
|
%install
|
|
%makeinstall_std -C build
|
|
|
|
install -m 0755 build/HandBrakeCLI %{buildroot}%{_bindir}/HandBrakeCLI
|
|
pushd %{buildroot}%{_bindir}
|
|
ln -s ./HandBrakeCLI ./handbrake
|
|
popd
|
|
|
|
desktop-file-install --vendor="" \
|
|
--remove-category="Application" \
|
|
--add-category="X-MandrivaLinux-Multimedia-Video" \
|
|
--add-category="X-MandrivaLinux-CrossDesktop" \
|
|
--dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/*
|
|
|
|
rm -rf %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
|
|
|
|
%find_lang ghb
|
|
|