gh/gh.spec
2020-04-01 10:34:18 +03:00

40 lines
785 B
RPMSpec

%define debug %nil
%define debug_package %nil
Name: gh
Version: 0.6.3
Release: 1
Summary: github cli
URL: https://cli.github.com/
Source0: https://github.com/cli/cli/archive/v%{version}/%{name}-%{version}.tar.gz
License: MIT
Group: Development/Other
BuildRequires: go > 1.10
BuildRequires: git
BuildRequires: upx
%description
gh is GitHub on the command line, and it's now available
in beta. It brings pull requests, issues, and other GitHub
concepts to the terminal next to where you are already
2working with git and your code
%prep
%setup -qn cli-%{version}
%build
%make
# bin package
pushd bin
upx %{name}
popd
%install
install -Dm0755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%files
%doc README.md LICENSE
%{_bindir}/%{name}