g/g.spec
Your Name 514b345b73
All checks were successful
Run CI/CD... / main (push) Successful in 5m56s
0.29.2
2025-02-20 19:27:53 +00:00

44 lines
1 KiB
RPMSpec

%define debug %nil
%define debug_package %nil
Name: g
Version: 0.29.2
Release: 1
Summary: A powerful ls
URL: https://g.equationzhao.space
Source0: https://github.com/Equationzhao/g/archive/v%{version}/%{name}-%{version}.tar.gz
License: MIT
Group: Development/Other
BuildRequires: go
BuildRequires: git-core
BuildRequires: upx
%description
g is a ls alternative with features:
- display items with type-specific icons and colors that are
easy to be customized
- display in various layouts ( grid/across/byline/zero/comma
/table/html/json/markdown/tree )
- user-friendly options with many aliases
- check file git-status when listing entries
- highly customizable sort option
- cross-platform ( Linux/Windows/MacOS )
- option to fuzzy match the path like zoxide with fzf algorithm
%prep
%setup -q
%build
export GOPROXY=https://proxy.golang.org,direct
go build -ldflags="-s -w" -o bin/%{name} .
upx bin/%{name}
%install
install -Dm0755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%files
%doc LICENSE *.md
%{_bindir}/%{name}