flux2/flux2.spec
Your Name 84e394a07c
All checks were successful
Run CI/CD... / main (push) Successful in 13m5s
2.5.0
2025-02-20 19:23:38 +00:00

62 lines
1.6 KiB
RPMSpec

%define debug %nil
%define debug_package %nil
Name: flux2
Version: 2.5.0
Release: 1
Summary: Continuous delivery solution for Kubernetes
URL: https://fluxcd.io
Source0: https://github.com/fluxcd/flux2/archive/v%{version}/%{name}-%{version}.tar.gz
License: ASL-2.0
Group: Development/Other
BuildRequires: go
BuildRequires: git-core
BuildRequires: upx
BuildRequires: kustomize
Provides: flux
%description
Flux is a tool for keeping Kubernetes clusters in sync with
sources of configuration (like Git repositories and OCI
artifacts), and automating updates to configuration when
there is new code to deploy.
Flux version 2 ("v2") is built from the ground up to use
Kubernetes' API extension system, and to integrate with
Prometheus and other core components of the Kubernetes
ecosystem. In version 2, Flux supports multi-tenancy and
support for syncing an arbitrary number of Git repositories,
among other long-requested features.
Flux v2 is constructed with the GitOps Toolkit, a set of
composable APIs and specialized tools for building
Continuous Delivery on top of Kubernetes.
Flux is a Cloud Native Computing Foundation (CNCF) project,
used in production by various organisations and cloud
providers.
%prep
%setup -q
%build
export GOPROXY=https://proxy.golang.org/cached-only
%make VERSION=%{version} build
upx bin/flux
# gen completion
bin/flux completion bash > flux-completion.txt
%install
install -Dm0755 bin/flux %{buildroot}%{_bindir}/flux
# install bash completion
install -Dm0644 flux-completion.txt %{buildroot}%{_datadir}/bash-completion/completions/flux
%files
%doc README.md LICENSE
%{_bindir}/flux
%{_datadir}/bash-completion/completions/flux