mirror of
https://abf.rosa.ru/djam/fasm.git
synced 2025-02-23 15:52:54 +00:00
54 lines
No EOL
1.2 KiB
RPMSpec
54 lines
No EOL
1.2 KiB
RPMSpec
%define debug %nil
|
|
%define debug_package %nil
|
|
|
|
Name: fasm
|
|
Version: 1.71.62
|
|
Release: 1
|
|
Summary: Flat Assembler
|
|
URL: http://flatassembler.net/
|
|
License: BSD
|
|
Group: Development/Other
|
|
Source0: http://flatassembler.net/%{name}-%{version}.tgz
|
|
Source100: %{name}.rpmlintrc
|
|
|
|
%description
|
|
Flat assembler is fast self-assembling assembler for DOS,
|
|
Windows and Linux operating systems. It was designed primarily
|
|
for the assembly of x86 instructions and it supports x86 and
|
|
x86-64 instructions sets with MMX, 3DNow!, SSE up to SSE4, AVX,
|
|
AVX2, XOP and AVX-512 extensions and can produce output in plain
|
|
binary, MZ, PE, COFF or ELF format.
|
|
|
|
%prep
|
|
%setup -q -n %{name}
|
|
sed '/thanks to/d' -i examples/elfexe/hello64.asm
|
|
find examples/ -type f -perm 755 -exec rm -f {} \;
|
|
find examples/ -type f -name "*.o" -exec rm -f {} \;
|
|
|
|
%build
|
|
%ifarch x86_64
|
|
pushd source/Linux/x64
|
|
../../../fasm.x64 fasm.asm
|
|
popd
|
|
%else
|
|
pushd source/Linux
|
|
../../fasm fasm.asm
|
|
popd
|
|
%endif
|
|
|
|
%install
|
|
install -d %{buildroot}%{_bindir}
|
|
|
|
%ifarch x86_64
|
|
pushd source/Linux/x64
|
|
install -Dm0755 %{name} %{buildroot}%{_bindir}
|
|
popd
|
|
%else
|
|
pushd source/Linux
|
|
install -Dm0755 %{name} %{buildroot}%{_bindir}
|
|
popd
|
|
%endif
|
|
|
|
%files
|
|
%doc *.txt examples/
|
|
%{_bindir}/%{name} |