efivar/efivar.spec
2024-02-25 13:54:27 +09:00

88 lines
2.3 KiB
RPMSpec

%define _disable_ld_no_undefined 1
%define date 20240201
%define major 1
%define libname %mklibname %{name} %{major}
%define develname %mklibname -d %{name}
Name: efivar
Version: 39
Release: 1
Epoch: 1
Summary: Tools to manage UEFI variables
License: LGPLv2.1
Group: System/Kernel and hardware
URL: https://github.com/rhboot/efivar
Source0: https://github.com/rhboot/efivar/archive/refs/tags/%{version}.tar.gz?/efivar-%{version}.tar.gz
#Source0: efivar-git%{date}.tar.gz
Requires: %{libname} = %{EVRD}
BuildRequires: pkgconfig(popt)
BuildRequires: mandoc
BuildRequires: glibc-static-devel
%description
efivar provides a simple command line interface to the UEFI variable facility.
%files
%doc COPYING README.md
%{_bindir}/efivar
%{_bindir}/efisecdb
%{_mandir}/man1/*
#---------------------------------------------------------------------------
%package -n %{libname}
Summary: Library to manage UEFI variables
Group: System/Libraries
%description -n %{libname}
Library to allow for the simple manipulation of UEFI variables.
%files -n %{libname}
%{_libdir}/*.so.%{major}*
#---------------------------------------------------------------------------
%package -n %{develname}
Summary: Development files for %{name}
Group: Development/C
Requires: %{libname} = %{EVRD}
Provides: %{name}-devel = %{EVRD}
%description -n %{develname}
%{develname} contains libraries and header files for
developing applications that use %{name}.
%files -n %{develname}
%{_mandir}/man3/*
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
#---------------------------------------------------------------------------
%prep
%autosetup -p1 -n %{name}-%{version}
%ifarch %{e2k}
# unrecognized options for lcc
sed -i '/^CFLAGS_GCC/,+1d' src/include/defaults.mk
sed -i 's/-MG//' src/include/deps.mk
# error: type qualifier is meaningless on cast type
sed -i src/include/defaults.mk \
-e 's/\$(ERRORS)/$(ERRORS) -Wno-error=ignored-qualifiers/'
%endif
%build
make -j1 \
libdir=%{_libdir} \
bindir=%{_bindir} \
CFLAGS="%{optflags} -Wstrict-aliasing=3" \
LDFLAGS="%{ldflags}"
# -Wstring-aliasing=3 enables slower but more accurate detection of
# aliasing issues than level 2 used by default, less false positives.
%install
%makeinstall