dolt/dolt.spec
Your Name 0f4d05cf5d
All checks were successful
Run CI/CD... / main (push) Successful in 1h25m36s
1.49.3
2025-02-21 20:56:21 +00:00

62 lines
1.2 KiB
RPMSpec

%define debug %nil
%define debug_package %nil
%define secscan 0
Name: dolt
Version: 1.49.3
Release: 1
Summary: Git for Data
URL: https://github.com/dolthub/dolt
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
License: ASL 2.0
Group: Development/Other
BuildRequires: go >= 1.22
BuildRequires: git-core
BuildRequires: upx
BuildRequires: pkgconfig(openssl3.3)
%if %{secscan}
BuildRequires: clamav
BuildRequires: trivy
%endif
%description
Dolt is a SQL database that you can fork, clone, branch,
merge, push and pull just like a Git repository. Connect
to Dolt just like any MySQL database to run queries or
update the data using SQL commands. Use the command line
interface to import CSV files, commit your changes, push
them to a remote, or merge your teammate's changes
%prep
%setup -q
# fix permissions
find . -perm 0755 -type f -exec chmod 0644 {} \;
%if %{secscan}
clamscan -ir .
trivy fs --scanners vuln --format cosign-vuln .
%endif
%build
export GOPROXY=https://proxy.golang.org/cached-only
pushd go
go build -o ../bin/%{name} ./cmd/dolt
popd
upx bin/%{name}
%install
install -Dm0755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%files
%doc README.md LICENSE
%{_bindir}/%{name}
%check
%if %{secscan}
clamscan -ir %{buildroot}
%endif