mirror of
https://abf.rosa.ru/djam/dahdi-tools.git
synced 2025-02-22 23:32:52 +00:00
204 lines
6.2 KiB
RPMSpec
204 lines
6.2 KiB
RPMSpec
%define tools_version 2.1.0.2
|
|
%define linux_version 2.1.0.3
|
|
|
|
Name: dahdi-tools
|
|
Version: %{tools_version}
|
|
Release: 8%{?dist}
|
|
Summary: Userspace tools to configure the DAHDI kernel modules
|
|
|
|
Group: System Environment/Libraries
|
|
License: GPLv2 and LGPLv2
|
|
URL: http://www.asterisk.org/
|
|
|
|
Source0: http://downloads.digium.com/pub/telephony/dahdi-tools/releases/dahdi-tools-%{tools_version}.tar.gz
|
|
Source1: http://downloads.digium.com/pub/telephony/dahdi-linux/releases/dahdi-linux-%{linux_version}.tar.gz
|
|
# pulled from upstream SVN, revs 5072 and 5074
|
|
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
|
|
BuildRequires: newt-devel
|
|
BuildRequires: libusb-devel
|
|
BuildRequires: perl
|
|
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
|
Requires: dahdi-tools-libs = %{version}-%{release}
|
|
Requires(pre): %{_sbindir}/useradd
|
|
Requires(pre): %{_sbindir}/groupadd
|
|
Requires(post): /sbin/chkconfig
|
|
Requires(preun): /sbin/chkconfig
|
|
Requires(preun): /sbin/service
|
|
|
|
Conflicts: zaptel-utils
|
|
|
|
#patch from https://issues.asterisk.org/view.php?id=15454
|
|
Patch0: dahdi-tools-modprobe_warn.diff
|
|
|
|
%description
|
|
DAHDI stands for Digium Asterisk Hardware Device Interface. This
|
|
package contains the userspace tools to configure the DAHDI kernel
|
|
modules. DAHDI is the replacement for Zaptel, which must be renamed
|
|
due to trademark issues.
|
|
|
|
%package libs
|
|
Summary: Library files for DAHDI
|
|
Group: Development/Libraries
|
|
Conflicts: zaptel-lib
|
|
|
|
%description libs
|
|
The dahdi-tools-libs package contains libraries for accessing DAHDI hardware.
|
|
|
|
%package devel
|
|
Summary: Development files for DAHDI
|
|
Group: Development/Libraries
|
|
Requires: dahdi-tools-libs = %{version}-%{release}
|
|
|
|
%description devel
|
|
The dahdi-devel package contains libraries and header files for
|
|
developing applications that use DAHDI hardware.
|
|
|
|
%prep
|
|
%setup0 -q -n dahdi-tools-%{tools_version} -a 1
|
|
ln -s dahdi-linux-%{linux_version}/include include
|
|
%{__perl} -pi -e 's/chkconfig:\s([0-9]+)\s([0-9]+)\s([0-9]+)/chkconfig: - \2 \3/' dahdi.init
|
|
|
|
%patch0 -p2
|
|
|
|
%build
|
|
|
|
pushd menuselect/mxml
|
|
%configure
|
|
popd
|
|
|
|
pushd menuselect
|
|
%configure
|
|
popd
|
|
|
|
%configure --disable-static --with-dahdi=`pwd`
|
|
|
|
make %{?_smp_mflags}
|
|
|
|
%install
|
|
rm -rf %{buildroot}
|
|
mkdir -p %{buildroot}%{_initrddir}
|
|
make install config DESTDIR=%{buildroot} PERLLIBDIR=%{perl_vendorlib}
|
|
install -D -p -m 0644 include/dahdi/user.h %{buildroot}%{_includedir}/dahdi/user.h
|
|
find %{buildroot} -name '*.a' -exec rm -f {} ';'
|
|
ln -sf ../../..%{_datadir}/dahdi/xpp_fxloader %{buildroot}%{_sysconfdir}/hotplug/usb/xpp_fxloader
|
|
rm -f %{buildroot}%{_sbindir}/sethdlc
|
|
|
|
%clean
|
|
rm -rf %{buildroot}
|
|
|
|
%pre
|
|
%{_sbindir}/groupadd -r dahdi &>/dev/null || :
|
|
%{_sbindir}/useradd -r -s /sbin/nologin -d /usr/share/dahdi -M \
|
|
-c 'DAHDI User' -g dahdi dahdi &>/dev/null || :
|
|
|
|
%post
|
|
/sbin/chkconfig --add dahdi
|
|
|
|
%preun
|
|
if [ "$1" -eq "0" ]; then
|
|
/sbin/service dahdi stop > /dev/null 2>&1 || :
|
|
/sbin/chkconfig --del dahdi
|
|
fi
|
|
|
|
%post libs -p /sbin/ldconfig
|
|
|
|
%postun libs -p /sbin/ldconfig
|
|
|
|
%files
|
|
%defattr(-,root,root,-)
|
|
%doc README LICENSE LICENSE.LGPL
|
|
%dir %{_sysconfdir}/dahdi
|
|
%config(noreplace) %{_sysconfdir}/dahdi/init.conf
|
|
%config(noreplace) %{_sysconfdir}/dahdi/modules
|
|
%config(noreplace) %{_sysconfdir}/dahdi/system.conf
|
|
%{_sysconfdir}/hotplug/usb/xpp_fxloader
|
|
%config(noreplace) %{_sysconfdir}/hotplug/usb/xpp_fxloader.usermap
|
|
%config(noreplace) %{_sysconfdir}/modprobe.d/dahdi.conf
|
|
%config(noreplace) %{_sysconfdir}/modprobe.d/dahdi.blacklist.conf
|
|
%{_initrddir}/dahdi
|
|
%{_sbindir}/dahdi_cfg
|
|
%{_sbindir}/dahdi_genconf
|
|
%{_sbindir}/dahdi_hardware
|
|
%{_sbindir}/dahdi_monitor
|
|
%{_sbindir}/dahdi_registration
|
|
%{_sbindir}/dahdi_scan
|
|
%{_sbindir}/dahdi_speed
|
|
%{_sbindir}/dahdi_test
|
|
%{_sbindir}/dahdi_tool
|
|
%{_sbindir}/fpga_load
|
|
%{_sbindir}/fxotune
|
|
%{_sbindir}/lsdahdi
|
|
%{_sbindir}/xpp_blink
|
|
%{_sbindir}/xpp_sync
|
|
%dir %{_datadir}/dahdi
|
|
%{_datadir}/dahdi/xpp_fxloader
|
|
%{_datadir}/dahdi/waitfor_xpds
|
|
%{_mandir}/man8/dahdi_cfg.8.gz
|
|
%{_mandir}/man8/dahdi_genconf.8.gz
|
|
%{_mandir}/man8/dahdi_hardware.8.gz
|
|
%{_mandir}/man8/dahdi_monitor.8.gz
|
|
%{_mandir}/man8/dahdi_registration.8.gz
|
|
%{_mandir}/man8/dahdi_scan.8.gz
|
|
%{_mandir}/man8/dahdi_test.8.gz
|
|
%{_mandir}/man8/dahdi_tool.8.gz
|
|
%{_mandir}/man8/fpga_load.8.gz
|
|
%{_mandir}/man8/fxotune.8.gz
|
|
%{_mandir}/man8/lsdahdi.8.gz
|
|
%{_mandir}/man8/xpp_blink.8.gz
|
|
%{_mandir}/man8/xpp_sync.8.gz
|
|
%{perl_vendorlib}/Dahdi.pm
|
|
%{perl_vendorlib}/Dahdi
|
|
|
|
%files libs
|
|
%defattr(-,root,root,-)
|
|
%doc LICENSE LICENSE.LGPL
|
|
%{_libdir}/*.so.*
|
|
|
|
%files devel
|
|
%defattr(-,root,root,-)
|
|
%doc LICENSE LICENSE.LGPL
|
|
%{_includedir}/*
|
|
%{_libdir}/*.so
|
|
|
|
%changelog
|
|
* Wed Aug 19 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 2.1.0.2-8
|
|
- fix bz 495453 (/etc/modprobe.d/dahdi.blacklist and /etc/modprobe.d/dahdi doesn't end with.conf)
|
|
|
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0.2-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
|
|
|
* Fri May 8 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.1.0.2-6
|
|
- Let dahdi-tools conflict with zaptel-utils (#472357).
|
|
|
|
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0.2-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
|
|
|
* Sun Jan 4 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.1.0.2-4
|
|
- Update to latest.
|
|
|
|
* Thu Nov 20 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.0.0-4
|
|
- Fix zaptel-lib(s) conflicts
|
|
|
|
* Sat Oct 25 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.0.0-3
|
|
- Add conflicts/requires to help make sure that we get dahdi-tools-libs and not zaptel-libs
|
|
|
|
* Fri Oct 10 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.0.0-2
|
|
- Don't package sethdlc even if it gets built.
|
|
|
|
* Thu Oct 9 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.0.0-1
|
|
- Cleanups suggested by reviewers
|
|
|
|
* Fri Oct 3 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.0.0-0.4
|
|
- Update to final release.
|
|
|
|
* Wed Sep 10 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.0.0-0.3.rc2
|
|
- Install dahdi/user.h header
|
|
|
|
* Mon Sep 8 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.0.0-0.2.rc2
|
|
- Update dahdi-linux to 2.0.0rc4
|
|
|
|
* Fri Sep 5 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 2.0.0-0.1.rc2
|
|
- First version for Fedora
|