mirror of
https://abf.rosa.ru/djam/compose-cli.git
synced 2025-02-23 00:03:01 +00:00
46 lines
983 B
RPMSpec
46 lines
983 B
RPMSpec
%define debug %nil
|
|
%define debug_package %nil
|
|
|
|
Name: compose-cli
|
|
Version: 1.0.35
|
|
Release: 1
|
|
Summary: Docker compose cli on GO
|
|
URL: https://github.com/docker/compose-cli
|
|
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
|
License: ASL 2.0
|
|
Group: Development/Other
|
|
BuildRequires: go
|
|
BuildRequires: git-core
|
|
BuildRequires: upx
|
|
BuildRequires: protobuf-compiler
|
|
Requires: docker
|
|
|
|
%description
|
|
This CLI tool makes it easy to run Docker containers and
|
|
Docker Compose applications in the cloud using either
|
|
Amazon Elastic Container Service (ECS) or Microsoft
|
|
Azure Container Instances (ACI) using the Docker
|
|
commands you already know.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
export GOPROXY=https://proxy.golang.org,direct
|
|
%make -f builder.Makefile BINARY=bin/%{name}
|
|
|
|
#upx bin/%{name}
|
|
|
|
%install
|
|
install -Dm0755 bin/%{name} %{buildroot}%{_bindir}/%{name}
|
|
|
|
%post
|
|
cd /usr/bin
|
|
ln -s docker com.docker.cli
|
|
|
|
%postun
|
|
rm -f %{_bindir}/com.docker.cli
|
|
|
|
%files
|
|
%doc README.md LICENSE
|
|
%{_bindir}/%{name}
|