codelite/codelite.spec

84 lines
2.1 KiB
RPMSpec

Summary: A powerful open-source, cross platform code editor for C/C++
Name: codelite
Version: 9.2
Release: 1
License: GPLv2+
Group: Development/Tools
Url: http://www.codelite.org
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
Source10: %{name}.rpmlintrc
Patch0: %{name}-6.0.1-desktop.patch
Patch1: %{name}-6.0.1-linkage.patch
Patch2: %{name}-5.4-libdir.patch
Patch3: %{name}-9.2_WordTokenizer.patch
BuildRequires: cmake
BuildRequires: wxgtku3.0-devel
BuildRequires: pkgconfig(freetype2)
BuildRequires: pkgconfig(gtk+-2.0)
BuildRequires: pkgconfig(libssh)
BuildRequires: clang-devel
BuildRequires: clang
BuildRequires: hunspell-devel
Requires: wxgtk3.0
Requires: xterm
%description
CodeLite uses a sophisticated, yet intuitive interface which allows
users to easily create, build and debug complex projects.
%files -f %{name}.lang
%doc AUTHORS LICENSE COPYING
#%{_bindir}/clg++
#%{_bindir}/clgcc
%{_bindir}/codelite
%{_bindir}/codelite-cc
#%{_bindir}/codelite-clang
%{_bindir}/codelite-echo
%{_bindir}/codelite-make
%{_bindir}/codelite-terminal
%{_bindir}/codelite_indexer
%{_bindir}/codelite_cppcheck
%{_bindir}/codelite_fix_files
%{_bindir}/codelite_exec
%{_bindir}/codelite_kill_children
%{_bindir}/codelite_xterm
%{_datadir}/applications/%{name}.desktop
%{_datadir}/%{name}
%{_libdir}/%{name}/
%{_mandir}/man1/*.1*
%{_iconsdir}/hicolor/128x128/apps/codelite.png
%{_iconsdir}/hicolor/128x128@2x/apps/codelite.png
%{_iconsdir}/hicolor/256x256/apps/codelite.png
%{_iconsdir}/hicolor/256x256@2x/apps/codelite.png
%{_iconsdir}/hicolor/32x32/apps/codelite.png
%{_iconsdir}/hicolor/32x32@2x/apps/codelite.png
%{_iconsdir}/hicolor/64x64/apps/codelite.png
%{_iconsdir}/hicolor/64x64@2x/apps/codelite.png
#----------------------------------------------------------------------------
%prep
%setup -q
#patch0 -p1
#patch1 -p1
%patch2 -p1
%patch3 -p0
%build
cmake -DPREFIX:PATH=%{_prefix} \
-DCL_INSTALL_LIBDIR:PATH=%{_lib} \
.
%make
%install
%makeinstall_std PREFIX=/usr
%find_lang %{name}
# To fix unstripped-binary-or-object
chmod 0755 %{buildroot}%{_libdir}/%{name}/*.so