closure-compiler/closure-compiler.spec

45 lines
1.3 KiB
RPMSpec

Summary: Closure Compiler - JavaScript compressor
Name: closure-compiler
Version: 20131014
Release: 1
License: Apache License
Group: Development/Tools
Url: http://closure-compiler.appspot.com/
# Source0Download: https://code.google.com/p/closure-compiler/downloads/list
Source0: http://closure-compiler.googlecode.com/files/compiler-%{version}.tar.gz
# Source0-md5: 37e8eb83d3fe271a002f41e7c2d1e2d7
Source1: %{name}.sh
Source2: get-source.sh
BuildArch: noarch
%description
The Closure Compiler is a tool for making JavaScript download and run
faster. It is a true compiler for JavaScript. Instead of compiling
from a source language to machine code, it compiles from JavaScript to
better JavaScript. It parses your JavaScript, analyzes it, removes
dead code and rewrites and minimizes what's left. It also checks
syntax, variable references, and types, and warns about common
JavaScript pitfalls.
%files
%doc README
%{_bindir}/%{name}
%{_javadir}/*.jar
#----------------------------------------------------------------------------
%prep
%setup -qc
chmod 0644 README
%build
%install
mkdir -p %{buildroot}%{_bindir}
install -m 0755 %{SOURCE1} %{buildroot}%{_bindir}/%{name}
# jars
mkdir -p %{buildroot}%{_javadir}
install -m 0644 compiler.jar %{buildroot}%{_javadir}/%{name}-%{version}.jar
ln -s %{name}-%{version}.jar %{buildroot}%{_javadir}/%{name}.jar