IMSProg/IMSProg.spec
2024-01-29 11:55:58 +09:00

96 lines
3.5 KiB
RPMSpec
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

Name: IMSProg
Version: 1.1.10
%global rel %{nil}
Release: 1
Summary: I2C, SPI and MicroWire EEPROM/Flash chip programmer for CH341a devices
Summary(ru_RU.UTF-8): I2C, SPI and MicroWire EEPROM/Flash программатор для CH341a устройств
License: GPL-3.0-or-later
Group: Development/Tools
Url: https://github.com/bigbigmdm/IMSProg
Source: https://github.com/bigbigmdm/IMSProg/archive/refs/tags/v%{version}%{rel}.tar.gz?/%{name}-%{version}%{rel}.tar.gz
Patch: IMSProg-1.1.10.patch
BuildRequires: cmake
BuildRequires: pkgconfig(Qt5Core)
BuildRequires: pkgconfig(Qt5Widgets)
BuildRequires: qt5-linguist-tools
BuildRequires: pkgconfig(libusb-1.0)
%description
IMSProg - Linux IMSProg - I2C, SPI and MicroWire EEPROM/Flash chip programmer
for CH341a devices. The IMSProm is a free I2C EEPROM programmer tool for
CH341A device based on QhexEdit2 and modify SNANDer programmer.
This is a GUI program used widget QhexEditor. For setting the SPI chip
parameters you can use the Detect button for reading chip parameters
(JEDEC information reading) or manually setting it. The I2C and MicroWire
EEPROM only manually selected.
The chip database format is clone with EZP2019, EZP2020, EZP2023, Minpro I,
XP866+ programmers. You can edit the database use the EZP Chip data Editor.
%description -l ru_RU.UTF-8
IMSProg - Linux IMSProg - I2C, SPI and MicroWire EEPROM/Flash программатор
для CH341a устройств. IMSProm является бесплатной утилитой для
использования CH341A устройств в качестве программатора микросхем. Основана на
QhexEdit2 и модифицированном программаторе SNANDer.
Графический интерфейс программы использует виджеты QhexEditor. Для настройки
параметров чипа SPI вы можете использовать кнопку «Поиск» для чтения параметров
чипа (считывание информации JEDEC) или настроить его вручную. I2C и MicroWire
EEPROM выбираются только вручную.
Формат базы данных чипов клонируется программаторами EZP2019, EZP2020, EZP2023,
Minpro I, XP866+. Вы можете редактировать базу данных с помощью редактора данных
EZP Chip.
%prep
%autosetup -p1 -n %{name}-%{version}%{rel}
# update translations
lrelease-qt5 IMSProg_editor/language/*.ts
lrelease-qt5 IMSProg_programmer/language/*.ts
%build
pushd IMSProg_editor
%cmake
%make_build
popd
pushd IMSProg_programmer
%cmake
%make_build
popd
%install
pushd IMSProg_editor
%make_install -C build
popd
pushd IMSProg_programmer
%make_install -C build
popd
# rename README
cp IMSProg_editor/README.md IMSProg_editor.md
cp IMSProg_programmer/README.md IMSProg_programmer.md
%files
%doc README.md IMSProg_editor.md IMSProg_programmer.md
%doc %{_docdir}/imsprog/html/index.html
%{_bindir}/%{name}
%{_bindir}/%{name}_editor
%{_sysconfdir}/imsprog/IMSProg.Dat
%{_bindir}/IMSProg_database_update
%{_datadir}/imsprog
%{_datadir}/applications/%{name}.desktop
%{_datadir}/applications/%{name}_editor.desktop
%{_datadir}/applications/IMSProg_database_update.desktop
%{_udevrulesdir}/99-CH341.rules
%{_mandir}/man1/IMSProg.1.xz
%{_mandir}/man1/IMSProg_database_update.1*
%{_mandir}/man1/IMSProg_editor.1*
%{_datadir}/pixmaps/IMSProg64.png
%{_datadir}/pixmaps/IMSProg_database_update.png
%{_datadir}/pixmaps/chipEdit64.png